Worksessions with Google Drive, Dropbox - Problem

Good Afternoon,

In my office we are starting using Workssesion in Rhino (first time). It’s a big architectural project and the team is divided into 2 physical places far away from each other. The internet is optical fiber, fast. There will be 3 people sharing the same 3d project, working in different parts of the project. We are trying to use OneDrive from Microsoft to share the files.

The problem
I don’t know why but we can open simultaneously the same file without the mensage apears:
“File is currently in use by the user “User2” on computer “FromPlace2”. File will be opened in ready-only mode.”

Lets’ give names: User1 in Place1 and User2 in Place 2. When User1 from Place1 opens a rhino file, Rhino generates in the User1 OneDrive folder the file “File.3dm.rhl”. After 2 seconds that file will be in User2 Place 2 computer, the file it’s 39 bytes and very fast to send. Although the file “File.3dm.rhl” it’s in the User2 computers, when User2 open the file “File.3dm” (that it’s in use by User1), Rhino simply opens the file as if it not in use.

I opened the “File.3dm.rhl” and it’s inside the text:
Tuesday, May 28, 2019”

Does Rhino ignore that file because it’s from a different user? We are using Rhino5 but i tried in Rhino6 and it happens the same.

Thank you in advance.

note: I also can activate a file in worksession although it is being used by other user, the same happens as a normal file.

Hello - I see this as well - let me see what I can find out.


Thank you Pascal

Hello - so, the answer is… you can’t do that… The file that is ‘locked’ by the presence of the rhl file on the local copy is the local file only - the one on the Google Drive ‘out there’ is not affected by the rhl file on your machine.


1 Like

Could be a option in one future update… For now we will try using a VPN with a share drive.

Thank you Pascal!

Adding Worksession.Event(s) in RhinoCommon would make it possible for us to create a lockfile where we want it to be. Hint, hint, hint. :slight_smile:

// Rolf

1 Like

What VPN service do you use for it? I tried Slick, Boleh, Ivacy… Boleh VPN (click here - click here to check the review) was the last I tested, seems like no issues.

Hello! Did you try what Hufferty offered? I had a similar problem, though with my streaming app. This free vpn for kodi helped a lot.

We have a true VPN, by the router, not by software.