Worksession - How to remove "File not found"?

OK, so I have (had) a file which is no longer found on disk, but there is no option in Worksession manager to remove a file which has been removed from disk. Such an option should be added.

So, of course I try a workaround by creating a fake file with this name and filepath, but then Rhino cunningly replies like so:

Hm. Now what? How do I clean out that missing file reference?

// Rolf

Hi Rolf - just highlight it in the list and poke ‘Detach’… does that do it?

-Pascal

No, all buttons are dead, except for Attach… :upside_down_face:

But what if you highlight that item in the list?

image

image

-Pascal

Yes, I tried that, but all buttons are dead except for Attach (sorry that my first screenshot didn’t show that I meant that the buttons were dead while selecting the missing file ref):

Like so. No option to detach:

// Rolf

Ok, I see - I tried to reproduce the situation and I was able to select and detach the file… let me have another go…

I get this on opening a rws file for which one attached file has been deleted:

---------------------------
Rhino 6  Open Reference File Error
---------------------------
Unable to read the reference file named

C:\Users\pascal\Desktop\Junk\SyncViews.3dm.

When Rhino is finished reading the work session file, you may 
use the "Worksession" command to edit the list of reference files.
---------------------------
OK   
---------------------------

then I see this, in Worksession:

and

So I am doing something different but I do not see what yet.

-Pascal

Try rename “SyncViews.3dm” and open Worksession. Then close WS and remove the file and try open WS again. Are you then out of option to detach?


BLOCK (Worksession)
I have another problem with Worksessions. if I open a file (part of WS) and start inserting a block, but then aborts the insertion before confirming the insertion, then I still see the Block’s layers show up in the file (not expected) but no block in the Block manager (as expected). And if I try to delete those layers it refuses due to a Block definition on the layers (which are not there, at least not visible in the block manager.

Solution: Close Worksession altogether and open the individual file, then it allows you to remove the aborted block insertion layers.

Perhaps this post should be split, but it seems to be a problem with Worksessions messing up files/references in runtime.

// Rolf

Hi Rolf - hmmm- so far it all works. …

-Pascal

Can it be related to me opening old R5 files and then saving them to R6 and… somehow Rhino gets messed up?
(But I did introduce Worksession only today, not in 2016 when the individual files were first created).

Hi Rolf - can you repeat the setup from scratch? If so, please give me the blow-by-blow, there is something I am missing…

-Pascal

Yup, I finally was able to reproduce:

  1. make Folder A\Model A.3dm
  2. make Folder B\Model B.3dm
  3. Set Folder A\Model A.3dm as the active model
  4. Save Worksession i Folder A and close it.
  5. Rename or delete Model A.3dm
  6. Open Worksession
  7. –> Detach not available for the missing file.

image

So #3 makes all the difference (If any other Model file is active when deleting Model A.3dm, then the error does not occur, so I also struggled with reproducing this… :slight_smile: )

// Rolf

Hi Rolf - thanks, I’ll test this.

-Pascal

Hi Pascal, has this been looked at lately? I also have the same issue.

Thanks

1 Like

Hi @pascal ,

Same issue here, no way to detach the missing file:

First few minutes working on my Worksession to experiment with it before integrating it into the workflows and this big issue pops up: Work Session Attach Failed.

image

The file is already attached to work session.

I make the wrong assumption

I will not use “set active model” until this bug is fixed because it destroy my first worksession.

Always buy design bug

  • In Layers, right-click and attach a model
  • Select that worksession reference and set it as Active Model
  • In the 3D select the model and delete it
  • Open worksession Manager
  • Try to delete the reference

The button “Detach” is hidden or inactive. If I try to attach that file a warning message pops up.
Expected: The button “Detach” is active and it is possible to take out the reference and reimport the reference file.

Hello - if I follow, you are trying to detach the active model…?

-Pascal

I try to make a video asap.

PS: Yes, I was trying to detach and attach but a warning “Work Session Attach Failed” pops up

Hello - ok - well, there the active model is not an attached model, so it cannot be detached. I’m not clear on what it is you are trying to accomplish.

-Pascal

1 Like

I was trying to be confident and looking at what the worksession was capable of.

Let say
I try to re-attach the file.

Video

Bug report: RH-57515