Wish: Rendered display mode with default ambient occlusion

I feel rendered display would really benefit a lot from having ambient occlusion added.
And some sort of shadows for rectangular lights.
(I think if you add a low res shadow map to it as if it were a spotlight pointing from the center, a soft shadow could be faked quite with better results than having no shadows like today)

EDIT: This happens when I set the environment strength very low (0.2), then the ambient occlusion drops too, and visually that doesn’t look right. I forgot to point that out!

This is on V6, I have not tried V7 for this though, so if stuff has been done then excuse my ignorance :slight_smile:

Here you can see the same scene with arctic, rendered and raytraced mode:

1 Like

This is what the same scene looks like with environment at default 1.0 and the rectangular lights deleted:

And for reference this is the same scene in raytraced:

So you see we need to set the environment really low to get good studio lighting, but in those scenes rendered mode no longer look so good. I hope that helps in shining some light on why I feel this is important.

And also why I for so long has wished for an exposure control. Setting up a studio scene requires a lot of tweaking of lights and environment to get the appropriate exposure…


@stevebaer can you take a look at this?
I see V7 has the same “problem” that the environment strength also affects the ambient occlusion strength. Imo ambient occlusion should either be left alone or have it’s own strength setting.
(Like it has in most game engines like Unity and Unreal (and twinmotion))


This is really something for @DavidEranen as he wrote the ambient occlusion shaders

1 Like

Good, thanks!

@Holo It looks to me like the rectangular lights are adding so much light that the SSAO shadows disappear. I don’t see environment intensity affecting SSAO.

Could you maybe further simplify the scene and describe what the core issue is? Or can you attach the scene exactly as it is in your first post?