Wierd Issues with Ambient Occlusion

Ive seen this in a few models now. I have a few meshes, but nothing very complex. I’ve checked all my normals and they are correct. I still I think this may be related to normals or objects not knowing how to shade their relationships?

I’m using arctic mode. I have a RTX3080 on windows 10, rhino 7 SR9. 16 gigs memory, i7 6700k

I really like using ambient occlusion shading for white models, but sometimes the shading jitters when navigating and some surfaces show up extremely dark. It doesnt matter if they are solids or open surfaces. Unfortunately when i do viewcapturetofile the jittered badly shaded output is the only thing that can come out.

the result:

I know ambient occlusion can be affected by zoom object (ZS, ZE) , but I am using saved camera’s so the zoom is fixed.

I have messed with my shadow memory with no avail but i’m experiencing this in default conditions. I wonder if it has something to do with the gamma adjustment settings as well.

has anyone else run into this?

Hi @benji.cox,

I actually haven’t seen this issue before. It would be really helpful if you could send us a model which shows this bug - it doesn’t have the be the full model. You can upload it confidentially here: Rhino - Upload to Support.


Thanks, I will. This is the second model of this size that I’ve run into this issue

Thanks for sending us the model @benji.cox,

I can reproduce the issue and have created a YouTrack item: https://mcneel.myjetbrains.com/youtrack/issue/RH-65518.


Thanks for taking a look. Let me know if gathering any system information is useful. I played with my system level settings yesterday at length without being able to solve the issues. I’m glad to know it exists on the rhino side.

I also tried setting the camera target distance much closer. even at that short distance there was still consistently strange shading happening, although at a different scale.

RH-65518 is fixed in Rhino 7 Service Release 11 Release Candidate