Wirecut IS sporatic...it didn't work for me, either


#1

Hello again:

This appears to be yet another coding problem. I selected WIRECUT, (I have used this function before) This is a straight cut, right though the model. I drew the line at both ends. The program then instructs me to “select objects to cut”…when I try to select the model in ANY window/viewport…NOTHING HAPPENS, which means the object can never be cut, and I can go no further.

WTF am I supposed to do now? This was originally a .3DS file that I opened and saved as a .3DM file. Why is this happening?

Thank you,

Carl S.


(David Cockey) #2

Is the object you are trying to a mesh object, not a polysurface/NURBS object? If so WireCut is behaving properly because WireCut only works on polysurface/NURBS objects. To use WireCut the mesh object will need to be converted to a polysurface/NURBS object. You can do so using MeshToNURB but the resulting NURBS object usually has many surfaces. A better strategy frequently is to use the imported mesh object as a reference for creating a new NURBS object.

Basic rule when using Rhino - don’t expect commands which manipulate geometery to work on mesh objects. Some do but many don’t.


#3

David: thank you for your reply.

I tried the MESHTONURBS. When I did, the original cut line re-appeared. After the conversion, I selected the model, but only the top of the model selected, at the cut line (I had pressed ESC on all previous attempts to use WIRECUT) . I tried to delete the unused bottom part, but I couldn’t select it. I then tried to copy the top part…then Rhino hung up (“not responding”) message. So I had to re-load it…it took FIVE MINUTES, and loaded TWO COPIES of the program. I just re-loaded it again, and it loaded two more copies of the program. Now there is a box in the center of the screen that says
"Welcome to Clayoo (not responding) …so I had to abort the load. I will be fucking with this for hours…

Karl S.


(David Cockey) #4

MeshToNURB creates a polysurface based on the mesh, and also leaves the mesh in place. Did you delete the mesh? If not when you used MeshToNURB you selected the polysurface which was cut, but the mesh was also there and not cut.

[quote=“Karl_Starke, post:3, topic:46007”]
. I then tried to copy the top part…then Rhino hung up (“not responding”) message.
[/quote]MeshToNURB can create very large objects which can cause problems, particularly if the memory available in your computer is limited (because of the amount of memory in the computer and/or other memory intensive applications are in use). This is one of the reasons I said frequently a better strategy than MeshToNURB is to use the imported mesh object as a reference for creating a new NURBS object. If you go to Properties, select the object you converted, and select Details in the Properties pane you can see how many surfaces are in the object.

[quote=“Karl_Starke, post:3, topic:46007”]
So I had to re-load it…it took FIVE MINUTES, and loaded TWO COPIES of the program.
[/quote]Sounds like a slow computer. How much memory does it have? Two copies opening is probably due to user input, such as clicking on the Rhino icon an extra time when there wasn’t an immediate response after the initial click(s). Exactly what steps are you taking to start Rhino?


#5

To start, I usually quick-click the short-cut twice.The machine has 8 GB of RAM.
I will try out your suggestions…thank you again…


(David Cockey) #6

Try clicking once and be patient. On my computer for icons on the initial screen which are not on the bar at the bottom I need to click twice. But for the icons on the bar at the bottom I only need to click once. Click twice on one of those (for any software, not just Rhino) and two copies of the software will open.

8 GB RAM should be sufficient for most Rhino models is Rhino is the only large user of memory running. But the combination of a model with many surfaces, such as one generated by converting a large mesh to NURBS, and other programs open which are using a lot of memory and you might run out.


(Kyle Houchens) #7

mesh to curbs is a janky command and makes janky models. It should be only used for really really specific circumstances, with really really low poly models,

have you tried the mesh booleans to do the split you are hoping for? they may work better and faster than screwing around with wire cut on a massively complex mesh to nurbs model.


(Jakob Normand) #8

Hi @Karl_Starke

There’s been a few post from you lately - all complaining about the shortcomings of Rhino and how the programmers are more or less incompetent. To me it sounds as if you need to actually learn how to use Rhino and also need to realise that all software has limits - that’s why so many of us use multiple 3D programs - Rhino, Swx, 3D Coat, Z-brush, Fusion etc. Each has it’s own advantages and Rhino just happens to have more than most. But… and this is the most important “but” of 3D software… no software is better than the operator! It is - no matter what the sales person told you - no easy task to create complex 3D objects. The result is seldom - if ever - better than the guy holding the mouse/trackball/stylus/space navigator. If you want to create 3D shapes you need to study long and study hard, learn from those who know, realise that you will be screwing up in the begining, and that your limited vocabulary will make explaining your problems/challenges seem likenan uphill battle. Keep fighting and keep learning!
-Jakob