Why suddenly such a large file size?

why suddenly such a large file size?

hello forum.

i have a problem with the memory size.
my component jumped from 200mb to over 2.xxgb.
I only built a few chamfers.
how can that be?

before i had some problems with polygon mesh. the creation often took a few minutes.

the component was originally built with subd and converted into nurbs. then i cut and built round edges and chamfers. now the big file size?!? But why??

the file size to high for upload here.
if you want you can use the dropbox link.


okay… i found one surface thats looks weird. i build it new and the file size shrink to 600mb.

but why…?

Hi @nik.mvk
Without seeing the file, it’s almost impossible to tell, but judging from the screen grabs, I’m seeing a lot of very dense isocurves; indicating a lot of complex surfaces resulting in a lot of complex chamfers. If the render mesh is set really fine, it can get quite large. Try and SaveSmall to see the file size for the NURBS geo only - although that will require a new render mesh to be generated when you shade the viewport, once again increasing the file size.
HTH, Jakob

hi normand,
yes, the files you find at the link “Dropbox”.

Dear @nik.mvk not a lot of people here in the forum will download a 2.xx GB file to analyse it.
you may want to follow Jakobs adavice and save it “save small” this will save the file without meshes.

check the tolerances and units (and do chamfer / fillet again with a suitable tolerance)
if your tolerances are to small, fillets / chamfers etc… will get very dense and have huge meshes.

check render mesh settings
check analyse mesh settings

if you still not find why the file is so big:
copy half of the geometry to a new file - check file size
do it a again visually half of the geometry to a new file → size ?
always repeat with the bigger file… this will somehow isolate some to dense geometry.

hope that helps - kind regards -tom

right… i understand.
under my first post i write i found the problem. one chamfer looks bad and i rebuild it. then it was better and the size “normal”.

Hi jakob, your way helps to shrink the file size again. from ca. 600mb to 250mb. :+1:

thank you for this advice. :slight_smile:

if your problem is solved and you do not expect other answers - just mark it as solution. - kind regards -tom

yes did it in the same time you write.
thanks for help.
nik :wink:

1 Like