Why is my Rhino shading all colorful

Rainbow Apocalypse!!

It used to be just red. Now its all colorful and runs slow. Does this have to do with any plugins that I installed? Thanks

Update: now it is not even associated with grasshopper. Every file upon launching looks like that with or without grasshopper running. I fixed it for a second, but its back again.
Also only in shading view, render view is all good

Magic :slight_smile:

double click the image sampler component, if you want it black&white make sure the click the corresponding little button in there.

Not sure if that is, its a guess. Provide a file for more help.

Probably not the project, because its all colorful on only a sphere.
Ahhh, its so slow
Does this have anything to do with the honeybee plugin?

Unless you have honeybee components on canvas I don’t think so.

Try uninstalling each plugin you have installed one by one until it goes away. It does look like the kind of coloring from Ladybug analysis stuff but I don’t know the plugin well enough.


Uninstall and Reinstall software

That might keep the setting that does this. Or if it is in your file you’ll keep getting this. As I said before. Provide the file at least to exclude it is from your file.

I’ve seen this on another PC, some week ago, can’t replicate the problem now.
The pc wasn’t mine but it didn’t have any plug-in installed as it was a student’s.

To me it seemed like IF grasshopper was turned on, something triggered the rendering of meshes with applied “normal colors”, with colors splitted and centered at world 0.

In the first pic all the blue spheres are probably on the same solid quadrant.

It happens to every file every project

Ok I figured it out guys, although just a temporal solution.
I tried uninstall many plugins, but none does the work.


I turned off launching grasshopper while launching Rhino, and it goes back to normal.
Still not sure which ladybug triggered it, but it works now.

Fuck it only works once. After reopening the file, it comes up again without grasshopper running at all

Update: first time launching every file its not showing, second time launching them the color shows up

Found a solution, quoting this post in German from 2013

search ‘OpenGL’ and check on UseCoreProfile

Save and restart Rhino it should go back to normal

Not sure what this setting means, but still works with grasshopper auto launch
hopes it help other people


Updated Solution: Even better, I found out that my monitor has been hooked onto the wrong portal

I have two graphic cards Intel HD 4600 w OpenGL 4.3
and a Quadro M4000 w OpenGL 4.6

And I have been using the HDMI portal on the HD 4600 this whole time
I just switched to the Quadro Display port
and I can now set the OpenGL.UserCoreProfile to false and the shading is still functioning correctly

1 Like

Very interesting.

@stevebaer is this something you care about? I think I saw it before one time but it wasn’t fixed then.

This is actaully interesting finding it looks to me like a world position map :face_with_monocle: