Why is my Artistic view not shading this object?

Sorry for the elementary question. I have the following scene setup:

For some reason, the boat object does not display shadows in the same way as the box. Why is this? I’m running Rhino 5.1 on OSX 10.10.5. Here are the Artistic settings (imgur album).

The thing is that I had tested this scene on Windows and the boat was shaded there, but I wasn’t sure whether it had something to do with different Artistic settings or maybe I just don’t understand well enough how materials or layer coloring affects things.

I’ve uploaded the Rhino file for anybody to check:
simpship.3dm (513.5 KB)

Hi! The faces you want to be shaded are reversed (the N direction is pointing outside). You can check it with Dir command. You better give your ship some thickness.

1 Like

Oh, I see. Should you always model solids in Rhino using surfaces of non-zero thickness?

Can you suggest the best way to deal with this? Would I explode the ship, and then extrude on each face? Is there a quick way to give each face a certain specified thickness?

Yes, you can explode, extrude, and Boolean it together, which might work in this case. The ship isn’t very precise, so I wouldn’t recommend solid offsetting.

1 Like

Okay, now I’m officially confused. I tried to extrude the different parts of the ship, and still the shadows did not show themselves. In fact, the shadow on the box (top left) had disappeared entirely.

However, I used the box tule to make a new cuboid, and the result is this newest one has the proper shadows. The normals for both cubes look good…I don’t understand how this difference arises.

simpship.3dm (543.3 KB)

That’s probably Mac-specific, because it looks OK in Windows.

there was (is?) a recent problem with this.

see this thread:


Under render background, select skylight.

@jeff_hammond: Thanks, I us downloaded the latest Mac WIP and that seems to help.

@Bill_Carson: Thanks!

I’m a bit confused about what the difference between Scene Lighting vs. Default Lighting in the Display properties does, and how Skylight affects this. Does Skylight just add a bunch of point lights high up in the sky?

Your guess on Skylight is as good as mine. It’s just I use artistic render alot and only get nice shading without lots of hassle using the Skylight option.

A couple of examples



In both cases I remove the background canvas effect as alot of these end in manuals and technical publications.


Oh indeed those are beautiful.

I would think that most of these are standard options from the Artistic/Pen view. The one question I have is about producing a non-uniformity in the line segments. For example, in the image of the oven, you notice on the outer edges on the lower right, there are small bumps in the line (the same for the boat example above). How is this controlled?

In the boat example, it’s due to a difference in colour between silhouette and line in the displays settings.

Are there other ways to add a bit of non-uniformity to lines? I know that certain renders (e.g. Penguin can do this).

In the case of the stove those bumps represent a folding point (cut out in the steel shell) and the very edge of the floor mount. Go into Rhino preferences, under Display Modes you have more control over how Artistic can be adjusted. My clients really like the pencil sketch look and makes it dead easy to laser print nice looking manuals.


Could you post a screen shot of your Artistic display settings? I’ve spent about the last half hour trying to get artistic to give me some gradient shading like you’ve got in your examples and I’m getting nothing.



Make sure that Shadows in Display Modes is set to “ON”


Otherwise, have a play with the settings and see what you get. Ideally use a model that has curved geometry as slab sided objects don’t support good shading.

i think it’s because of the light in your scene.

in the latest WIP, this is your model in the default artistic display:
(i’ve made one change to default artistic and that is ‘show lights’ )

here, i’ve deleted the light:

Bill, your renderings are simply AWESOME. I have tried to replicate the effect, but it seems in the last version I am using the artistic settings have been changed, or I didn’t quite get the way you did it.
Can you share your magic? I work in mechanics too, and that would be exactly what would get great results for a brochure I am working on now.

Seems to be working OK in current version and WIP I would really love to see artistic as a render option on it’s own for doing really large images. You probably need to post an example of what you are drawing. The geometry is quite important in getting good shading. If you look at the pin, other than the end shading and the visible isocurve the part is near invisible from some angles.

Hi Bill,
tinkering around I found a good way of getting some decent results.
I am using the PEN display, adding the shadows and changing line thickness.
saving with -view_capture to file I can get files as big as I need changing the parameters. Of course the same line thickness will apply to scaled up or down file size, but it is judst a matter of finding the right balance among file size and line effects.
It is still too precise, for what I want to achieve, but, a good start already.

This one is a scaled down version of a size the double in pixel size.

1 Like

That’s a heck of a multi-axis mill-drill-turn machine… ! --Mitch