When using rhino it seems to hang for 2-3 seconds when entering new commands or changing viewport


#1

can anyone help, when accessing a new command or changing view port rhino seems to hang like its doing something and can take a little time to update or access the new command. This happens when working with files with very little data, for example 2 rectangle curves, so it isnt video card related to too much data. anyone with any ideas why this is happening?


(Wim Dekeyser) #2

Is this on the Windows or Mac version?
Does it happen with all commands or just a few?
Can you post details on the Rhino version and your system?


#3

its on windows 10 and pretty much all commands seem to have a 2-3 second delay when going into them. I am running rhino 5 latest update


#4

Rhino 5 sr12


#5

i7 2.5ghz 8gb ram 64bit


(Wim Dekeyser) #6

What about your GPU and also, does it go away if you run Rhino in safe mode?


#7

geforce gt 540m, in safe mode it seems to be fine


#8

What custom plugins have you installed? If you have any.
Probably a plugin doing something.


(Wim Dekeyser) #9

My first hunch is that it is video driver related. when were those updated last?
Apart from that you can try to allow plug-in by plug-in and see which one is causing the problem.


#10

thanks all for your input guys i think it may be plug in related i have quite a few in the system and some specialist ones which may be causing the issue


#11

Do you have a space-pilot / 3D navigator? This caused a delay problem for me one time … and it was frustrating as hell before I figured it out.

The fix is to ‘re-calibrate.’ If it gets out of alignment, then it sends a a signal to Rhino reporting that it’s in use, when it’s not. So, Rhino waits … and waits.


#12

Hi, I have got the same problem, but I coul´nt fix it with the solution which you described. I tried recalibrate my SpacePilot pro when Rhino is shut down or when it is running, but with no solving the problem of freezing. What exactly have you done, please?
Thank you


#13

My problem and solution were fairly specific, so it can be hard to figure out which crazy variable(s) are affecting your system. Assuming it is space-pilot related, I would uninstall the space-pilot app & drivers, re-boot, and then re-install the latest space-pilot software from the website. Make sure Rhino is not running until you are finished.

You might want to try using Rhino before you re-install to see if the lag problem is gone. That would be interesting to know!

Don’t forget: when you are calibrating, you should not touch the space-pilot device. It’s trying to determine its neutral/base-line setting.


#14

Thank you for your answer. I have tried unistall and reinstall again the software before. I try it combine with the recalibration. It is interesting ,that anytime when i unplugged my SpacePilot, Rhino works fine. And all this lagging started before aprox. 2 months, The time before , I used it with no problem. But thank you!


#15

Good luck!

You might also try moving the space-pilot to another USB port. I have had one or two ‘go bad’ on me in the past. Rare, but real.