Rhino/SpacePilot Pro - Freezing Rhino window switching from other software to Rhino

rhino5
rhinowip
unhandled

#1

Hi, I have a problem with Rhinoceros and SpacePilot Pro.
When I switch from any another program (for example Fusion 360, Magics 20, etc…) to Rhino or between two instances of Rhino, the Rhino window freezes for 5-10 seconds, after that it work properly.
After many attempts, I tried to turn off the 3D Connexion driver and the problem disappear.
I tried different 3DConnexion driver (now the lastes version), no problem between other softwares, only with Rhinoceros (both Rhino 5 sr 13 and Rhino 6WIP).

Can anyone help me to solve this problem? It’s very tedious.


#2

Exactly the same problem for me! Any suggestions?


(Nathan 'jesterKing' Letwory) #3

Hmm, I can’t reproduce this problem with Rhino WIP (I don’t have Rhino 5 installed on my dev box).


#4

I have Rhino 5 :confused:


#5

Hi @eca_rp , i have the same problem, I have an old space xplorer,
have you solved the problem?

Thank you in advance


#6

Hi HANSIO,
I have an open ticket with the 3DConnexion Technical Support at the moment, since october 2016.
After many emails, I got no solutions yet.
I wrote an other request today.

I think the problem is the 3DConnexion plugin for Rhino (5 and 6 WIP), I found a temporarly trick disabling the 3DConnexion plugin as showned in the image. So, I can use the button but I can’t navigate the space.


#7

I too have noticed this behaviour, although the delay on my system is only a second or two. I think it’s a recent issue for me, in the last six months or so. Not sure what has changed - I’ll perhaps check my drivers.

I’m using Rhino 5 with a SpaceMouse Pro.


#8

I had the same problem with last a few versions of 3Dconnextion drivers (10.4.x). Yesterday I installed older version of 3Dconnextion driver (10.3.0) and freezing takes ~1s only. I can’t find version 10.2.0 to install and check but most probably the freezing will disappear.


(Nathan 'jesterKing' Letwory) #9

I realized just now that I am not using drivers at all. Maybe that helps?


#10

I try the following procedure and now all works fine (from 3Dconnexion Technical Support).

  1. Close Rhino

  2. Kill driver

  3. Delete %appdata%\3Dconnexion\3DxWare\Cfg\Rhino.xml

  4. Restart driver

  5. Use ONLY Rhino button settings and camera control settings from popup menu

a.

b. http://docs.mcneel.com/rhino/5/help/en-us/options/3dconnexion.htm