When I use "GSA" in "Grasshopper", an error happens

plugin
unhandled

(Y.Kate) #1

When I use “GSA” in “Grasshopper”, an error happens

I try to open the sample in the following sites to connect Grasshopper and GSA.


・ [Grasshopper GSA Form Finding Examples]

110604 soap film 1.gh (38.2 KB)

However, I seem to run out of some components by an error at a stage to read it in grasshopper
The lower screen is a state of the error
0602_GHQ_gh%20gsa

I imported
・BullAnt for Rhino
・IFC
・TEKLA
・GSA (Oasys General Structural Analysis)
to a rhino

Do you know what it is caused by? Thank you in advance for your help.
Momiji.


(David Rutten) #2

It’s not really an error so much as a message telling you you need to get a license to run that plug-in.
Did you get a license which doesn’t work?


(Y.Kate) #3

“sdrGenerateCHS”,“sdrNetworkToMesh”,“sdrCurvesSplitIntersect” of this object which does not work
But, I do not understand what kind of component is necessary


(David Rutten) #4

They might be components in that plug-in that is complaining about not having a license. It may prevent itself from loading if no valid license is found, which in turn means its components won’t be available when you open a file that contains them. Either these are two completely unrelated problems, or getting a license will allow you to use those components and the second problem goes away as it is only caused by the first.


(Y.Kate) #5

Is the license a thing of Grasshopper? Or is it a thing of the GSA?


(David Rutten) #6

It’s GSA. Grasshopper comes free with Rhino and doesn’t expire.


(Y.Kate) #7

I seemed to forget to acquire what’s called “Request Free Trial License”.
I seem to send you to solution.Thank you!!

I seem to cut it for this line sense acquisition at 10 ~ 24 hour. When an error happens, after the license acquisition, I ask you a question again. Thank you very much for your help.


(Y.Kate) #8

I put “Request Free Trial License” in を hand and connected it

However, a similar result was provided at the time of input in Grasshopper.

The image such as the second piece image “0602_GHQ_gh+gsa2” which I rode did not appear first

And it was the state that could be connected to GSA in Rhinoceros

Do you know how you obtain “sdrGenerateCHS”, “sdrNetworkToMesh”, “sdrCurvesSplitIntersect?” Thank you in advance for your help.
Momiji.


(Luis Fraguada) #9

@geometrygym, any idea?


(Y.Kate) #10

Here was “sdrGenerateCHS”, “sdrNetworkToMesh”, explanation of “sdrCurvesSplitIntersect”, but does not understand a method to install


#11

Hi @fraguada, thanks for tagging me in this thread.

StructDrawRhino (sdr) is the original reference name for the plugin now named Bullant. Unfortunately some of these examples are years old and I have little time to go back and update all of them with new references.

If the components are not loading, then this is typically caused by the state of Coff loading for grasshopper. I have not been able to identify the reasons why this is required to be in a different state for some users. Run rhino command grasshopperdevelopersetiings and change the tick box state for coff loading. Restart rhino and should be problem solved.

Also refer to www.geometrygym.com/installing

Let me know if this helps or not.

Cheers

Jon


(Y.Kate) #12

You’re very kind.
I installed “BullAnt Rhino6 v1.4.01.msi” again and tried it

And I rebooted rhinoceros and opened Grasshopper

However, “GeoGymBIM” put on "http://www.geometrygym.com/installing” was not displayed.

Does the cause know what it is? Thank you in advance for your help.


#13

Run GrasshopperDeveloperSettings again, and untick the COFF checkbox shown on that dialog. Restart rhino and see if BullAnt loads. I don’t know why some users need that in a specific state (sometimes it has to be ticked, other times it’s the opposite).

Let me know if that doesn’t fix the problem.

Cheers,

Jon


(Y.Kate) #14

I carried out “GrasshopperDeveloperSettings” again

And I remove a check button and reboot rhinoceros

After opening “PlugInManager”, “BullAnt” was read afterwards

However, a similar error has happened.
Thank you in advance for your help.


#15

Thanks for trying that, it’s the typical cause for Grasshopper not loading the components. is there any error message listed in the rhino command prompt window as Grasshopper starts?


(Y.Kate) #16

Any error is not taking place at the time of the “Grasshopper” start in “rhino command prompt window”

Any error is not taking place at the time of the “Grasshopper” start in “rhino command prompt window”

I seem to read “GSA” in “rhino command prompt window” when I push “Close” here


(Y.Kate) #17

I installed “BullAnt” of a slightly old version in accord with “http://www.food4rhino.com/app/bullant

It is “bullantrhino6v1307.msi”

Then an error disappeared when I read “GHfile”

One of three of the sample changed. It is the following models


110606 force density.gh (23.4 KB)

However, in 110606 “analysis properties” and 110606" soap film" except it, an error happened on Grasshopper and was not able to make a model


110604 soap film 1.gh (38.2 KB)

Do you know what it is caused by? Thank you in advance for your help.


#18

Good to hear you progressed, although I’ve been specifically building the Rhino6 plugins and this might be the cause.

I’ve rebuilt the Bullant plugin and tested all 3 form finding samples. Can you please try updating to this build?
https://drive.google.com/file/d/1et13eQ720jLO075g6Y3CKVSLrbjqypHu/view?usp=sharing

If it is still not working, let me know the error message on the red components.

Cheers,

Jon


(Y.Kate) #19

You’re very kind. I tried it in a new version
0602_GHQ_gh%20gsa13

However, the same error has happened at the time of reading of “GHfile”

0602_GHQ_gh%20gsa14

Also, when I watch the red error of the sample file of “110606 soap film”

The error message is “1. Solution exception:Request for generated beam has coincident node points and is ignored at node 1 -0.002,-0.0025,0.002”


(Y.Kate) #20

As a result of having watched two programs that did not work normally

It came to be displayed when I doubled the scale of dimensions 1000

Setting of my GSA might be set in “mm” not “m”

The model of “110606 analysis properties” moved well

However, the model of “110606 soap film” remains flat without becoming in the form of membrane structure

Do you know what it is caused by? Thank you in advance for your help.