What is the best 2 methods for creating a top roundish surface from the partially completed 3D model?

What are my best 2 or 3 options for creating a surface, preferably without doing hoop de hoops or round about ways to get things done, in order to create a turtle shell like surface of my mouse? Mouse from start of Level 2 training materials for Rhino 6. Right now, I decided to use 1 rail sweep surface from 4 base curves and each one goes up, and then kind of creates a singularity I guess. I’m not sure this is causing me to not be able to use the ‘join’ command (next to the explode tool icon) on it or not. But, I’m getting an error when trying to join the bottom ‘open polysurface’ to the top ‘open polysurface’. Is there another command to join them, or is it a dead end and I have to use another better tool to get things done?

TrackballSIDEproj7.3dm (539.8 KB)

Hello - here is one way.TrackballLofted.3dm (467.4 KB)


1 Like

TrackballSIDEproj10.3dm (587.3 KB)

I noticed if I do a 1 rail sweep, and then use Edge Tools/Join 2 Naked Edges that while it does make it into a solid, it renders poorly as it has creases where it went up into the singularity point at the very top of my mouse. So, seems like ‘loft’ is the best tool. Not sure how to best use it in this situation and with this model having the bottom completed and wanting just the turtle shell top part made and connected, to end up both smooth and technically a ‘closed solid polysurface’. I’ll take a look now at your file for loft and see if I can guess how that was done… hold on.

OK, I had a look. And tried to make a simple loft with 4 open curves. See file; see the small loft next to the mouse.TrackballSIDEproj11loft.3dm (443.1 KB) and I even tried only 3 of the 4… best outcome you’ll see in the file. But, why does mine say it’s a polysurface and your file has the loft as a regular surface? Also, I couldn’t get it to be correct using all 4 open curves and failed to get the curvature of the middle rung as you’ll see in my file. LOL… I cannot even make a simple loft in Rhino (yet)! What am I doing wrong or am I missing a needed step? The surface that was lofted in your file (Trackballlofted.3dm) has 3 open curves, but magically got that middle rung as part of the loft… how? Whoever had that file either didn’t bother to leave the curve that was the middle rung (but used it) or never had it and somehow magically got that loft to appear with good curvature.

…honestly, I’m considering just never using loft and always using file>insert instead at this point because I just went into the file you put up here in chat again and tried deleting the loft (after extractwireframe command to get the middle rung back) and then using the ‘loft’ command to do a loft myself on that same exact wireframe it was created successfully on (probably long ago using Rhino 5, LOL) and couldn’t do it myself… it’s just not giving me good results no matter what settings I use for that loft tool… so, thinking I should just delete everything in your file and rename/resave it as some other name and then have an already done loft I can just edit using control points/gripper/gumball… pppfffffftt :roll_eyes: :weary:

OK. I used the surface and edited it from your file you gave above. It worked! I got done with the mouse with a clean /smooth and totally problem free 3D model of a trackball mouse. TrackballFINALandCOLORED.3dm (1.5 MB)

…still the loft command/tool doesn’t work correctly and not nearly good enough for something like this (the top part of the model). It must be working in Rhino 5, but not hardly in Rhino 6 (yet).

I’ve never used Rhino 5 before, nor any before that version either. Only 6 and a bit of 7 WIP. I’m guessing. Someone, somehow got loft to work… I tried several times… that tool just won’t work even in the original file above after deleting it and trying it based on curves that worked for someone before me. Those curves worked for someone else… why not me?

Well remember this is just kind of a dumb little example model that’s meant for an instructor to just gauge where you’re at, and primarily to see if you understand that most things with NURBS have to be made by thinking about larger surfaces that you have to trim off, instead of trying to just loft or sweep the whole thing.

You evidently used the StraightSections option, which does…well what you did there.

Here it is; the messed up loft I’m was talking about above. See? I tried all the other settings… don’t help nearly enough. Still pretty much just as messed up. Oh, and ‘strait sections’ option was ONLY option in that area of the tool options pop up window.TrackballLofted2.3dm (408.5 KB)

You can’t “loft” curves that cross. Start Loft, pick the left, top, and right curves in order, and that should work.

You can in the sense that the command will execute, but the result may not be as expected.

Click on the arrow pointing down icon on the right side of the menu to see the drop down selections.

I did… still only gives me that strait option… nothing else but one more ‘strait sections’ option

That is very strange. I can not reproduce it.

To confirm that I understand correctly.
You start the Loft command
Select the input curves and enter
The pop-up panel for Loft appears.
You click on the icon circled in the image below.
The menu drops down but the only choice is “Straight sections”

Is that correct?


1 Like

@mercury1978kevin Have you customized the User Interface? Are you running any plug-ins?

Run the Rhino SystemInfo command and post the results here.

yes, that is correct. Exactly what is happening. But, didn’t know there was an order for loft I have to click in to get it to work right… but, would that make it not give me any other choices than Strait sections?

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-L2P7VFO

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon ™ RX 580 (AMD) Memory: 8GB, Driver date: 5-25-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 20.5.1 27.20.1017.1011

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 5-25-2020
Driver Version: 27.20.1017.1011
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\SimLab\Plugins\SimLab Rhino 6 Integration\SimLabComposerIntegration.rhp “SimLab Composer Integration”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The only other way I know to use Loft is:
Select the input curves
Start the Loft command
Select the input curves and enter
The pop-up panel for Loft appears.
If a different Style is desired click on the icon for the drop down menu and select the style.
Click on OK or enter to complete the command.

Just a guess but try blocking the loading of:
C:\Program Files\SimLab\Plugins\SimLab Rhino 6 Integration\SimLabComposerIntegration.rhp “SimLab Composer Integration”