What is the best 2 methods for creating a top roundish surface from the partially completed 3D model?

Strange behavior which I don’t recall seeing anyone report before. You may need to wait for someone from McNeel to assist.

ya… goodnight… will deal with this 2morrow, but I do have a TON of plug ins loaded; it would be a nightmare to uninstall all of them (a dozen)! Hopefully I’ll dream of Rhino working better 2night, LOL c U 2morrow

You can try starting Rhino in Safe Mode which prevents any plug ins from loading and see if the problem persists.

Start Rhino in safe mode

Safe mode is a method of opening Rhino with features disabled that might be the cause of crashing.

Safe mode is not designed to be a working mode – it is a troubleshooting, problem solving mode.

Use safe mode if Rhino crashes immediately on starting, crashes when shading, or crashes when running commands that are part of a plug-in. Please report all problems crashing Rhino to the Rhino development team.

If you launch Rhino in safe mode, the following items will be disabled:

● Any start-up commands listed in General Options.

● Command line scripts specified by the “/runscript” argument.

● All plug-ins.

● Templates.

● OpenGL shading.

To open Rhino in safe mode

On the Windows Start button, under Programs, select Rhinoceros in Safe Mode.


Do drop-down menus in pop-up panels for other commands work properly?

Start the Zebra command and select a surface. Under “Strip size” click the down pointing arrow to drop down the menu. Do you see seven choices from “Thickest” to “Thinest”?

Start the CurvatureAnalysis command and select a surface. Drop down the menu under “Style”. Do you see four choices?

Another test is to use the command line -Loft version of the Loft command. This version uses the command line for selecting options instead of a pop-up panel. Note that the first character is a dash “-” not an underscore “_”. There is also an underscore version which has a different purpose.

Type -Loft in the command line and enter. Select the input curves and enter. The command line should display “Chose loft option” followed by the loft command options. Click on “Type”, or type “T” and enter. The command line should now display the five type options for selection.

Hey all - if Loft finds some, but not all of the inputs meet cleanly at the ends, then only ‘straight sections’ is offered, to avoid loopy edge or self-intersections at the almost-singularity.


1 Like

Thanks. That is not one which I had encountered before. It explains the command line message about “Some but not all ends meet” in @mercury1978kevin screenshot. On the other hand I tested the curves in the file Kevin uploaded and didn’t have any problems. Either I wasn’t using the correct curves in the upload file or the file he uploaded is slightly different than the one he was using.

What the hell’s happening!? It’s suddenly working now! Yes, zebra works to get ALL 7 options for me from it’s drop down menu; I can see all 7 options for that one. My file has a loft when loading it… I thought I had it where it was only a wireframe… crazy stuff. But, I showed you screenshot proof, so we both know it’s not just my imagination that I had a problem and wasn’t able to see more than one option for the loft command.

It would seem that the wacky combination of curves you were trying to Loft fit the case where it sets that as the only option, as Pascal said.

no, no… I did a window select and did it successfully that way… even though just yesterday I did the same exact thing along with choosing one curve at a time in proper order (I tried all possible combos) and it did not work then

TrackballLofted4.3dm (496.7 KB) <Now I’m getting the same error, but had to go back to version 2 of the above file (was seeing it do a loft successfully in version 3 of my files using the red lines). These black lines in this file where derived from the original lofted surface using the extractwireframe command F.Y.I. So, it should work correctly. Crazy, huh? Why do the red lines work correctly but not the black lines? Does not make any since. Here is version 3:TrackballLofted3.3dm (486.9 KB) and again, the version 2 you’ll find way above in chat here: TrackballLofted2.3dm (408.5 KB) and the original unedited file given to me by someone on the forums: TrackballLofted.3dm (467.4 KB)

OK, I did it in different orders of clicking and while I do see a difference in the result of the loft, I DO NOT SEE that it gives me problems. I do not see that it does not display all options in the pop up window for loft. That is today on the original file… but, just yesterday I swear I did the same exact thing and it did not work. I showed you screenshot proof above… but even using this same original file (unedited) it did not work… so that is why I even went to the trouble of extracting wireframe from that loft in that original file and getting black lines with a cross section curve… feels like a hacker who now decided to fix my problem (only after causing it in the 1st place… maybe)