What is going on here?

What is causing this artifact? Shaded mode, default lighting, 0% gloss.

Can you post the file please?

Hey, this is the Moon eclipse from a few weeks ago :slight_smile:


I think so … jajajaja

Hi @airpainter

This looks like the bug that got introduced in SR6… but is now fixed in SR8. Are you seeing this in SR8? If you’re not using SR8, please try it and let me know if you’re still seeing this. If you are using SR8, then I’m going to need more than a picture… Setting the Shaded mode’s “Gloss” to 0.0 works just fine here. If you’re using a custom display mode, then export it as well.

In the mean time, I will look at SR7 and lower and see if I can reproduce it there.

Let me know…


1 Like

I’m still not able to repro this in SR7 or SR6…so it’s possible this is a completely different problem… So I’ll need your display mode and example file that I can use here.


I take that back…after further pounding… I managed to get this…

Which is pretty close to your image…and is caused by the bug I mentioned… SR8 fixes this.


I checked for updates and none available, I’m running SR-7. I don’t see SR 8.

You have to subscribe to SR Candidates in Rhino Options > Updates and Statistics > Update frequency.

OK, I’ve updated Rhino to SR-8 and the weird shading is gone, however, there is still a shading issue. It looks like a shadow but very light, not as dark as before. Update, This seems to be related to the shading option of custom material for all objects. The effect goes away if Object’s color or Single color options are chosen.