Wallacei and Topos

Hello, we are trying to run Wallacei with Topos but are facing a problem because the Topos “Optimus” component runs on a Toggle. We’ve tried connecting a trigger and counter to manually change the toggle from True to False every 10 minutes, but this has no effect on the changes Wallacei has on the Genes. Is it possible to tell Wallacei to make changes at a special time interval? Or any other ideas on how we can make this work? Thanks !!

Hi Raphael,

I wish I could run Topos on my system to do some debugging for you, but unfortunately I can not. Any timer or trigger does not work for sure. if you upload an image of the GH definition for me to take a look at, I may have some ideas.

Hello Milad, thank you so much for reaching out to us.

I wasn’t able to make it work because Wallacei is constantly changing the genes no matter the input into the objectives even if it’s null. I think these 2 plugins aren’t compatible unfortunately, it seems to only work with Karamba, Kangaroo and Ladybug, it wasn’t designed to work freely with just any addons… Soooo I’ve decided not to use Wallacei this time, but launch the script in repeat so that we can choose from the list which one we prefer, all variables are randomized, there are no objectives.

Wallacei is designed to work with almost every other plugin. But since the public version of Wallacei is controlling the canvas for the big generative loop, any other live loop within the Wallacei loop needs to be done in a zombie mode for now (only outputting the results).
Having said this, I have an idea: I think you can make Topos solver to act as a zombie solver by changing the preview option of the Topos solver to “Final Preview” (right click on the solver). Next thing is that you need to get rid of the timer. Next, connect a boolean toggle instead of a button to reset input of the Topos solver. and for run input, connect a slider from 0 to 1 (false/true) define it as a gene (wlc_) so Wallacei changes it every time it runs. By doing this, you are triggering the Topos solver in a zombie mode within the big Wallacei loop, I think! Let me know how it goes over there. I still could not find a way to run Topos on my system.

Hello Milad, ok so it actually seems to be allllmost working now. Regarding the reset toggle, I am leaving it on False, because Topos automatically resets whenever the inputs change, so that’s good. However, the Run input is still a problem. Topos actually needs to switch back the Run toggle to False, after the simulation entirely ran, to generate the final shape. So, when I connect the 0 to 1 slider to Wallacei, it doesn’t generate that final shape that is then measured for creating objectives, I guess that when it changes all the genes, it automatically resets and we lose the previously generated model. Therefore, the solver is empty and I get the following message: “Get objective(s) failed”. Thanks !!

20230307 - for forum.gh (66.4 KB)
hi @milad.showkatbakhsh , i have the same problem as raphael using wallacei with topos. I tried every suggestion in this thread and here’s what i found.

  • topos’ ‘run boolean’ to start the solver is a bit different from others. in live preview mode, it is possible to define it as a gene (wlc_) because topos still produce the final mesh when it changes to “0 (false)”. but in final preview mode, topos actually needs the freedom to revert it back to “false” as soon as it finish the process, otherwise it only gives out the unsolved mesh (refer to attached images).
  • so here, what i need is a kind of ‘special boolean toggle’ that wallacei can set to “1(true)” to start every new generation, but let the topos change it to “0(false)” whenever it wants, and then wallacei set it to “true” again, etc…
  • i tried using the “stream filter” component from grasshopper, but topos seems to be not able to change it when the boolean toggle is not directly connected to its solver.

i have attached the gh file,… please let me know if i am missing something, or if there’s other workaround you can think of.
thanks in advance!