Wall Section Layers Visible at Openings


(Djhg) #1

Two Images below (Shaded View but issue’s the same in all view modes):

One: Openings layer turned on, 1/2" frame in opening style.

Two: Openings layer turned off (or less than 1/2" frame set in opening style) shows the wall layers (if it has any.) How do I get a clean surface shown on wall edges? Wrapping settings on wall style don’t change it ( though I thought the ones for “Openings” might…)


#2

Hi, openings should respect wall wrappings as doors or windows do. I suspect what happens here is that you have a wall style composed by 2 layers, and both of them have the same “type”. In order that wrappings work, there must be “Normal” and “Core” layers, so normal ones can wrapp around the Core one. So you can tell one of these wall layers to perform as the Core layer, so the other one “Normal” one, will wrap around it.
In that case, as you will notice, you will need to add a new exterior wall layer in order to do not see the border of the wall layer that wrapps around the other.


(Djhg) #3

Thanks Francesc. This is great.

But there seems to be a limitation. For a theatrical flat which has plywood on only one side, that side can’t be the first layer at the top of the layer list (with the core the second layer) and respond correctly to the wrapping settings. I can’t get it to work on the attached project with Wall Style “FlatSided1A”, which has this layer order. It only works with “FlatSided1B” where the layers are reversed.SetDraftingTest1 007.3dm (9.9 MB)


#4

Why not? can’t you move it up with the arrow?
Keep in mind that you can also set the general wall style wrappings to “Interior”.


(Djhg) #5

If I

Yes, but it’d be the same as the other Wall Type. I need two types, one with the layer on one side, one with the layer on the other - or I have to be too disciplined about what direction I draw the one wall type in.

For me, changing the wrapping style between interior and exterior has never made a difference; and I’m not clear on what the terms refer to, either.


#6

Then it’s already fine in your file. You have two wall styles with two layers, one that has the thicker layer (Core) in the exterior side, and the other one that has the thicker layer in the interior part.

Keeping in mind that “Normal” type wall layers will wrap around “Core” type layers, if you have the wall style Wrapping settings to “Exterior”, then, when the “Normal” layer is in the Exterior side, the wrapping will be visible. If the “Normal” layer" is in the interior side, the wrapping won’t be visible.
The order of wall layers displayed in the wall styles dialog go from the interior to the exterior.


(Djhg) #7

Thanks Francesc. I think I get this enough to implement it!