Voronoi lattice with continuous straight edges that are not welcome!

Hello, after using the code in 3D elongated Voronoi design I created a voronoi structure with straight edges, not edged as the start up example.
I noticed that whatever I do, there is a vertical continuous edge from top to bottom as seen in the attached image.

This appears in cylinders as well as in other shapes.
I tried a cone for exampe, same continuous straight line appears again.
I cannot understand why this is happening, I am guessing the reason might be the solid difference and the fact that voronoi3d poppulates voronoi points in a box initial distribution.

Is there any way NOT to create this peculiar straight line automatically? It ruins all the randomness of the constrution. Thank you!

VORONOI_CYL_0.2.gh (26.8 KB)
VORONOI_CONE_0.2.gh (29.4 KB)

1 Like

Here’s a solution I cobbled together some time ago. It requires the Dendro plugin which does things that are mysterious (to me at least), but it’s the end result that counts, yes? The MDiff at the end is to give the geometry a flat bottom so it can be 3D printed.


VoronoiBowl.gh (14.5 KB)

VORONOI_CONE_0.2 Edited V0.gh (22.5 KB)
Multipipe is not working.

I don’t know how robust this is… I created a Cull Seam cluster that seems to work in both your files:

VORONOI_CONE_2023Jun5a.gh (29.6 KB)
VORONOI_CYL_2023Jun5a.gh (27.5 KB)

Your problem are the edges that are produced by the pipe I replaced it with a cylinder so I can extract the seam and then removed the edges that have zero distance from it. There might be better solutions though. (same thing applies for the cone)

one tip: I am guessing you used pipe to place it bellow the floor. as you can see, if you plug the bottom vertex to the base of the cylinder you can have the same result.

Edit: @Joseph_Oster 's solution seems better. I saw his as I was uploading this…

erase.gh (26.4 KB)

Thank you all for your excellent sollutions and your immediate help.
I will need some time to study them of course !

Thank you very much. I will probapbly get back to you with some questions !

Hello again, after examining and trying to understand better the examples you provided I noticed a couple of things I am sharing with you.

Both the Joseph_Oster and the Aris examples seem to adress the problem as I understand by deleting the unwanted edge after it has been created. Moreover at the base of both of these solutions, and the original gh file that I stareted with which I just now noticed, there are (only at the base) 3 unwanted connections that actually do not intersect with anything (no nodes when they cross other lines). Is there a way not to create the unwanted edges at all in the first place instead of deleting them ?

Quan Li’s sollution does not seem to have this issue at all, but I cannot realy follow it because it is too complex for a novice user such as myself.

Thank you again everyone.

UPDATE: When I move a little bit the Box of the Poppulate3d, the unwanted edges at the bottom dissappear!

In my pc, I don’t have these lines. It might be your rhino unit settings:
(Rhino/File/Document Properties/Model Units/ absolute tolerance)
it is generally advised to have this at 0.001 or lower, otherwise it affects the precision of the calculations.

Thank you, my settings already had 0.001 tolerance, the bottom lines dissapear only if I move the popullate Box.

Here’s a way to use Multipipe.
You’ll need Topologizer.

VORONOI_CYL_0.2_re.gh (17.1 KB)


Thanks for this solution master.
There is way to make these face planer without kangaroo?

More studying for me! Thank you !