VisualArq / Rhino.Inside Revit problem

Hello!
Jumping on the Rhino.Inside Revit train… there seems to be a problem with the VisualArq/Tibidabo plugins.
When I open Rhino 7 in Revit, the plugins seem to load fine.
image
However, the VA toolbar does not show up, and all the VA commands don’t work (those of Lands Design do!)
I’m aware of your announcement that VA 3.0 will connect with all the parametric glory, but after all, 2.9 should already be working. Anything I can do?
Thanks!

Hi Eugen!
We have noticed a similar problem to run VisualARQ inside Revit when VRay is also installed in Rhino. I don’t know if it’s your case, and I don’t mean it’s Vray’s fault, but we still need to figure out how to fix it.

There is a manual workaround, if this is your case:

  1. Close Revit and Rhino.
  2. Find a file called “VisualARQ.Script.dll” in this directory: C:\Program Files\Rhino 7\System
  3. Move it to this folder: C:\Program Files\AsuniCAD\VisualARQ 2\RHINO7\System
  4. Try to run Rhino and VisualARQ Inside Revit again.

Let me know if this still doesn’t work for you and we will try to find a different solution.

Thank you Francesc, that worked! VRay, then. Very odd bug…

I did it and still cant get VA in RiR. I even unninstalled Vray but it wont appear.

Hi @Leonardo_G_Pate, make sure you have installed VisualARQ 2.9 for Rhino 7 before running Rhino from Revit. Try a VA command before opening GH in order to ensure VisualARQ has loaded correctly.

Hi,

Chaos group has a fix available for this problem since 2021-03-24 here.

1 Like