Problems loading VisualArq

Yes, none were installed, and I installed “Tibidabo” successfully but “visualARQ” was unsuccessful and it showed following error:
“Unable to load VisualARQ.rhp plug-in: application initialization failed.”

Hi @massyya70,

If neither Tibidabo or VisualARQ were listed in the Rhino Plug-in Manager, then there is a problem with the VisualARQ installation.

Please, try to uninstall VisualARQ and Lands Design (if you have it installed) and reinstall it again.

Which version of Rhino do you have installed?



I have Rhino 6.20 .
And yeah, the problem started when I installed lands design.
Is there any problem to have both (“visualARQ” and “lands design”) installed?
I need both.

It worked.
Thank you.
How can I have “Lands Design” with “VisualARQ” ?

Hi @massyya70,

Yes, install last versions of both plugins:

  • VisualARQ 2.7
  • Lands Design RC3



Oh, yes.

Hi I have the same problem only when I’m using Rhino inside revit the plugin visual arq does not run, tried the installation process as above but an error keep coming up, what can I do to fix the issue?

Hi Scott,
Check this Topic: VisualArq / Rhino.Inside Revit problem - #2 by fsalla
A similar problem was reported some time ago. It should be fixed already, but just in case, try that out. Also, make sure you are running the latest VisualARQ version (and VRay’s).
Please let me know how it goes.

Hi Francesc
I did exactly as instructed to resolve the problem It worked well, ThankYou so much
A little problem has occured and its the first time encountering it, the plugins are installed but its failing to

  1. Create Hatch and to load
  2. Custom profile, I have tried food4rhino and reinstalling latest update of Visualarq

1 Like

Hi Scott, What VisualARQ version are you using? just make sure you have the latest one: Download - VisualARQ
Let me know if you still get the same problem.

Hi Francesc
I have uninstalled and reinstalled visual arq, I think it’s the bridge between rhino inside Revit and grasshopper, because when I run visual arq grasshopper alone in rhino no errors pop up, but when I launch rhino inside Revit and start grasshopper visual arq the error messages appear.
Could there be a file that needs to be moved into a system file?

*All plugins are available, it is only when rhino inside is running they are missing.
*I’m also following the tutorial video Revit families to Visual Arq and the custom profile plugin is missing error shows up when rhino inside Revit is running

1 Like

Maaaaaaan, thanks for showing it I thought it was my fault


I have a a lot of errors while starting rhino.inside but i didn’t the problem that cause this problem and yes I get the hatch error at the end
after uninstalling visualarq, rhino inside ran smoothly without any error

@fsalla please fix this errors

1 Like

@user992 we suspect that this error has to do with the fact the ironPython plugin was not loaded in the moment of loading VisualARQ. We have just released a new update of VisualARQ which fixes this error. VisualARQ 2 - Version 2.12.4 released
Please install it and try to run VisualARQ inside revit again. Let me know if the problem persists.

1 Like

It works like a charm Now :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:
thanks for your fast response @fsalla

1 Like

same error appears is there a way to manual install the ironPython plugin or move it to a required file

Hi Scott -
You are running a cracked version of Rhino. It’s difficult to know what happens in those…

1 Like

Okay noted Thank You

I am having the same issue of VisualARQ not loading at start up.

I can force it to run by dragging the visualarq.rhp file from C:\Program Files\Rhino 7\Plug-ins\Tibidabo into the rhino window but i need to do this each time i start rhino. Any tips greatly received.

I am running the latest Rhino and Visualarq and visualarq isnt showing up in the plugins but Tibidabo is active. I have tried a clean install but it hasnt helped. There is perhaps a clash with our internal Rhino install somehow but havent heard of anyone else having the same issue and it works on my other computer.

Hi Martin,

Try to do it as indicated in this post: Installation issue "Unable to load VisualARQ.rhp plug-in" - VisualARQ
After you do it once and restart Rhino, you should not need to do it again.

Thank you, that seems to have worked well. Thanks Francesc

1 Like