Visual bizarre artifacts


Does anybody have experienced something like what you can see in the screenshots?
It happened all of a sudden and its happening with all files.
I have re-installed to no avail. Needless to say it’s rather impossible to do any kind of work here.
My machine is a Macbook pro 16 / 2019. Recently updated to Monterey (maybe three weeks ago, no issues before today)
Perhaps you might come up with an idea!

Hi Robin -
Is this file-specific or does this also happen with a simple box in a new file from a factory-default template?

Hi Wim

Thanks for getting back.
A simple box looks like this (see below). There are a few edges missing.
Before realising that the issue affects all existing files, I have tried to copy-paste a portion of the file in a new clean template but the problem persists.
Don’t know what to think really. I would blame it on the Mac had it shown some other visual glitches in other software but everything looks fine.

Thank you

Hi Wim

I played around and added a sphere. Here are the results.


Hi Robin -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim

Here’s the paste

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17002, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Educational, build 2022-01-10
License details: Cloud Zoo

Apple macOS Version 12.1 (Build 21C52) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-IT (MacOS default)

AMD Radeon Pro 5300M OpenGL Engine (OpenGL ver:4.1 ATI-4.7.101)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4080 MB
Graphics: AMD Radeon Pro 5300M
Displays: Color LCD (264dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5300M (4 GB)
Color LCD (1792 x 1120 @ 59.00Hz)

USB devices
VIA Labs, Inc. : USB3.0 Hub
Logitech: USB Optical Mouse
VIA Technologies Inc. : USB 2.0 BILLBOARD
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices

Third party kernel extensions

Third party plugins
/Users/robinrizzini/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot10Rhino7Plugin.rhp/libkeyshot_rhino_plugin.dylib

Rhino plugins that do not ship with Rhino
/Users/robinrizzini/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot10Rhino7Plugin.rhp “KeyShot10RhinoPlugin”

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.14.22010.1002
/Applications/Rhino “PanelingTools” 7.14.22010.1002
/Applications/Rhino “Renderer Development Kit” 7.14.22010.1002
/Applications/Rhino “Displacement” 7.14.22010.1002
/Applications/Rhino “Legacy Rhino Render” 7.14.22010.1002
/Applications/Rhino “Commands” 7.14.22010.17002
/Applications/Rhino “Import_OBJ” 7.14.22010.17002
/Applications/Rhino “export_xaml” 7.14.22010.17002
/Applications/Rhino “QuadRemesh” 7.14.22010.17002
/Applications/Rhino “export_OBJ” 7.14.22010.17002
/Applications/Rhino “RDK_EtoUI” 7.14.22010.17002
/Applications/Rhino “Export SVG” 7.14.22010.17002
/Applications/Rhino “MeshCommands” 7.14.22010.17002
/Applications/Rhino “Export_DAE” 7.14.22010.17002
/Applications/Rhino “PDF Export” 7.14.22010.17002
/Applications/Rhino “IGES Export Plug-in” 7.14.22010.17002
/Applications/Rhino “Import_SVG” 7.14.22010.17002
/Applications/Rhino “BlockEdit” 7.14.22010.17002
/Applications/Rhino “Export_AMF” 7.14.22010.17002
/Applications/Rhino “Rhino Render” 7.14.22010.17002
/Applications/Rhino “Import_DST” 7.14.22010.17002
/Applications/Rhino “PLY - Polygon File Format Export” 7.14.22010.17002
/Applications/Rhino “Import_AMF” 7.14.22010.17002
/Applications/Rhino “RhinoCycles” 7.14.22010.17002
/Applications/Rhino “IronPython” 7.14.22010.17002
/Applications/Rhino “Grasshopper” 7.14.22010.17002

I’ve just run into this problem this morning as well. Yesterday all was working fine and when I came back to my computer to work on the model it had all weird artifacts. I hadn’t shut down the computer, app, or closed the model.

I restarted Rhino 7 and it did the same thing. I also tried other files and same issue.

I checked for an update to Rhino and it said I was on the latest service release.

I then checked and updated to the latest Monterey update and did the same steps and still the issue persisted.

My final step was to turn of ‘gpu tessellation’ and everything cleared up and gave me at least a functional workspace for the simple model I’m working on, but I worry about handling large models without full use of the graphics card.

Hello. After an initial exchange with Wim the issue solved itself. I opened rhino after a couple of days and everything was fine. The program went into a sort of reset (snap settings etc) as if it was just installed. Mistery to me…
Good luck!

Thanks for the update. Hopefully that is the case for me!

Had the same problem just today, it started in the office after a minor crash of Rhino 7 on the Mac…
After spending half the day looking for potential problem sources, not finding a solution, I went home frustrated and woke the Mac at home, with the last idea of playing around with the graphics settings of Rhino… At home everything worked fine, with any settings whatsoever, and there are only two differences between the working setup at home and in the office: at home my internet connection is a lot faster and more stabile, and while going home the working temperature of the Mac was reduced from app. 90° Celsius to app. 50° Celsius… I have no idea what that should have to do with a graphic glitch, but that is it. (all other GFX-intense works and software did not show any faulty imagery btw…)

Hi Hidden Fortress,

In the preferences>view>OpenGL can you toggle the GPU tessellation? If this doesn’t resolve the artifacts can you send us the file along with your systemInfo (type in Rhino Command Line) along with a link to this thread.

Upload to McNeel


Hi… thanks for the help :slight_smile: … i had no problems with toggling… in fact this is what I wanted to try at home, but it had no effect… did not make a difference. At home the machine started without artifacts again right away, and i toggled back and forth, but could not repeat the error… so the actual only differences were operating heat of the system and a faster internet connection

I’ve now seen two cases where this happened on a system where a laptop was connected to an external monitor. I wonder if that’s also the case in your setup.