Visibility of dimensions in model view


#1

Probably a newbie-level question, but is there a way of hiding dimensions in model view that have been added in detail views? Can’t see a way, but isn’t the point of detail views to show stuff you don’t want cluttering up your model drawing?


(Brian James) #2

Try the command HideInDetail in the detail in question. The counterpart is ShowInDetail if you need it.


(Pascal Golay) #3

Hi David - can you place the dimensions in the layout space rather than activate the detail and put them in the model space? On top of the detail view, not in it…

-Pascal


#4

Thanks guys. I probably didn’t explain very clearly: I would like to be able to add a dimension in a Detail without it showing up in Model space. So, Brian, it’s the opposite problem - hiding it in the Model viewport. Sorry to mislead.

The suggestion about putting it in the Layout space works (thanks Pascal): you do not then see it in Model space. But this seems counter-intuitive. For one thing, it makes the positioning of Dimensions and the creation of Details more complicated. Secondly, Help says: “To correctly reflect model geometry, add dimensions in the detail viewport.” And thirdly (!), as I say, is it not desirable to be able to keep such objects out of model space?

Puzzled, but thankful for the solution!


(Pascal Golay) #5

Hi David, I guess a more flexible solution would be to place all dims on a layer or group of layers that you simply turn off at the top level when working in modeling space. But I understand the problem you are describing…

-Pascal


#6

It was pretty cool when back in the day for a few seconds we had the ability to turn layers off in model space but have them on in details. It in my opinion handled situations like this pretty elegantly, and I for one would love to see it back.

Thanks,
Sam


#7

So this facility was once available? I vote to have it back!

Thanks again for all suggestions.