Viewport problem after upgrade to 5.3

settings
viewport

#1

Hello,

I just updated to the latest Rhino for Mac-Version 5.3 (5D191) and since I expirience the same problem with all files and also if I create a new file:

Every time I open a new file, I can see only two viewports instead of all four. I then have to find the border (completely on the right or on the left) of the viewport and have to drag it to the middle with the mouse. Even when I save a document with the adjusted viewport setup, it opens next time with only two viewports visible instead of all four.

I work on a iMac with OS 10.8.5

Thats what it looks like every time I create a new document or open a file…

I can then drag the windows smaller so that the other viewports appear (this time it was from left side… other times i had to drag from right…):


(Rodrigo Bárcena) #2

@Sebastian1, please see: https://discourse.mcneel.com/t/5-3-5d191-only-shows-two-viewports/40568


#3

Getting this message when I try your link…


(John Brock) #4

There is a problem with 5.3 running under 10.10 and older.
You’ll either need to downgrade to 5.2.4, or upgrade your Mac to 10.11 or 10.12.


(Kelvin Cheng) #5

@elkooo, the post is in the private section of the forum. Please try the new WIP that should have the fix. Please let us know how it works. We need to confirm the fix really works before we offocially release the next update. Thanks.


(Rodrigo Bárcena) #6

@elkooo sorry, that was my bad, I inadvertently linked you to a private section of discourse. I think my colleagues have already pointed you the existing you workaround


#7

@KelvinC,

Thanks for mentioning the WIP.
Just installed it - seems to work flawlessly on my System (OS 10.8.5, Core i7 iMac), as far as concerning the mentioned viewport-problem.

Will stick with the WIP until the next regular Release is coming.

Thank you, keep up the good work :slight_smile:


(Dan Belcher) #8

The 5.3.1 update to Rhino 5 for Mac should fix the issues with blank viewports on OS X 10.10 and earlier.


#9

@dan,

seems like the viewport problem is indeed gone now… but my pallette has only one row now each time I reopen rhino / create a new document (see picture)

Now I must no more manually adjust the viewport size but instead I have to adjust the palette size every time. WIP 5.4 (5E12W) does it too.
It seems like the size of the pallette changes randomly every time I create a new document… If I repeatedly create new documents with the app open, the pallete size is different with every new document…


(Marlin Prowell) #10

Please post your Rhino info:

  • Navigate to Rhinoceros > About Rhinoceros.
  • In the lower left corner, click the More info… button.
  • The Rhinoceros Information panel opens. Click the Copy to clipboard button. This copies the contents of the tab to your clipboard.
  • Paste the copied computer description into the post or email.

Also post the file generated by the ExportPreferences command.

Thank you.