Problems after software update 5.3 (5D191)


#1

After installing the 5.3 update Rhino now fails to open files. From the welcome screen or documents folder, two outcomes are experienced. Either Rhino crashes, or this screen appears.

I would greatly appreciate advice on how to fix this problem, please.


Saving as PDF issues
(Dan Belcher) #2

Looks like you are running Mavericks (10.9.5). Is that correct?

We have been getting similar reports of this from Mavericks users and are looking into these. Until we figure out what is going on, you have a couple of options…

  1. Update to a more recent version of OS X or macOS.
  2. Roll-back to Rhino for Mac 5.2.4.

Sorry about the inconvenience. We’re looking into a fix.

-Dan


#3

FWIW I am using 10.9.5., and I do experience some problems in opening files (Rhino crashes), but not consistently.
I have reported the latest occurrence to McNeel.

Max.


#4

I’m running Yosemite and am having the same problem.


(Dan Belcher) #6

Hi All-

Just an update on this issue. We are aware of a number of issues with the 5.3 update (5D191) when running on versions of OS X 10.10 (Yosemite) and earlier:

We are receiving crash reports as well as viewports not displaying properly (MR-3018). We are looking into both these issues right now and hope to get these fixed as soon as possible.

If - for some reason - you are unable to upgrade to OS X 10.11 (El Capitan) or macOS 10.12 (Sierra), it is possible to temporarily roll-back to Rhino 5 for Mac 5.2.4.

-Dan


(Dan Belcher) #7

#8

It seems to me the file open problem does not occur if I close the most recent flle window first. However, I have had other weird crashes.


#9

this did the trick.

Thanks

Please let us know when you’ve fixed the bugs so we can update, until then 5.2.4 will do.


#10

Same crash problems here in 5.3 with Yosemite (10.10.5). Reverting to 5.2.4.


(Dan Belcher) #11

(Dan Belcher) #12

Hi @ddeschen, @itailu, @bigjimslade, @maxz, @Martin_Lines-

We have what we hope are some fixes for these issues in the latest RhinoWIP (5E12w). We would like your help testing the latest RhinoWIP to see if it resolves the issues you are seeing before we publish an 5.3.1 update.

Please let us know if 5E12w resolves these issues on your machine.

Thanks,
-Dan


#13

Dan, I will download the interim version and try it but not before sometime next week because of my current work load


#14

Hi Mc Neel,
After upgrading to 5,3 (5D191), i have serious problems with the command “Select object by name”.
After selecting a name in the list of the pop up window and clic the close button, Rhino just freeze or sometimes crash.
i’m working on a 27Mo file, with 300 surfaces with textured images (links are ok, and all images are less than 1Mo each)

Could you fix that because i use quite often this command?

Best regards,

I’m on a IMac 5K (late 2015), 3,2Ghz core i5, 32Go RAM, AMD Radeon R9 M390 2048 Mo, macOs el capitaine (10,11,6).


(Dan Belcher) #15

We have heard reports of this. Please check out this topic. We have not (yet) been able to reproduce them on our computers.


#16

Hi @dan
I confirm that the problem of closure of Rhino using _SelName command is still there.
I sent a report.
Simon.


#17

Thx Dan.
For your information, i run on a french version of rhino.
Best,


(Dan Belcher) #18

The 5.3.1 update to Rhino 5 for Mac should fix the issues with blank viewports on OS X 10.10 and earlier.