Right-Click to choose wireframe, shaded, render, etc gone in 5.4?

Hi Jamol-

Sorry for the delayed reply…this slipped off the radar.

This should not be happening.

Can you please provide some additional information? Please navigate to Rhinoceros > About Rhinoceros > More info… > Copy to clipboard and paste the content back into a reply here.

Software information

Software versions

Rhinoceros version:  5.4  (5E407)

Rhinoceros path:     /Applications/Rhinoceros.app

IronPython version:  5.1.2015.131

Language:  en-US (MacOS default)

macOS version:  Version 10.12.3 (Build 16D32)

Plug-ins

None

Third party kernel extensions

BB87-189075721B57

com.avatron.AVExVideo (3.0.1) 7F642CAD-514F-3539-9DF1-A36ABDC91352

com.focusrite.driver.FocusritePCIe (4.6.1 236)

96C2DF55-7A3A-3000-9DC3-40268B453659

com.waves.driver.soundgrid (9.7.99) no UUID

com.paceap.kext.pacesupport.snowleopard (5.9.1)

25206F6A-6BC3-E93C-C31E-371502C8CE8E

com.avatron.AVExFramebuffer (3.0.1) BFD0F9D1-9058-33E8-A76A-F36E52F64C0E

Hardware information

Computer hardware

Hardware model:  MacBookPro10,1

Processor:  Intel Core i7-3615QM CPU @ 2.30GHz

Memory:  8 GB

Architecture:  Intel 64 bit

Video hardware

Graphics:  NVIDIA GeForce GT 650M 1024 MB

Memory:  1024 MB

Screen size:  1440 x 900

Displays:  Color LCD (221dpi 2x)

USB devices

Apple Inc.: FaceTime HD Camera (Built-in)

Apple Inc.: Apple Internal Keyboard / Trackpad

Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

None

OpenGL information

OpenGL software

OpenGL version:  2.1 NVIDIA-10.14.20 355.10.05.15f03

Render version:  2.1

Shading language:  1.20

Maximum texture size:  16384 x 16384

Z-buffer depth:  24 bits

Maximum viewport size:  16384 x 16384

Implementation settings

Use texture compression:  No

Appearance settings

Antialiasing:  4x

Mip map filtering:  None

Anisotropic filtering:  None

Hey Jamol-

The first thing I would try is updating macOS Sierra (looks like you are on 10.12.3; the last Sierra was 10.12.6). You might just want to update to macOS High Sierra.

The second thing to try would be to run macOS in Safe Mode - this would disable all the third-party kernel extensions you have installed (temporarily) to see if they are causing the problem.

Let us know how it goes,
-Dan

Hey Dan-

Alright will try! I normally hold back on upgrading since I also run my
music studio plugins and software from this computer as well! But I think
it may be safe to upgrade by now. Will let you know how it goes.

PS. Feel like I’m in a class room all over again as my last teacher’s name
was Dan Also. lol Thanks for responding.

1 Like

Please let us know what you find. We’ve heard a couple similar reports and we’re trying to get to the bottom of this one.

(So many) Dans

Hey Dan,

Upgrading did not affect the viewport at all. I’m Currently downgrading
since I lost functionality in other (music) programs I use as well. I was
just probably going to cut my losses and see if I can possibly downgrade
Rhino as well? Not sure yet though.

Thanks for trying these steps out. I’m sorry they did not work. We’re hearing this complaint from a couple of users and we’re really not sure yet what is causing this to happen.

Yes, it is possible to roll-back to 5.3.2.

No worries mate. So I reinstalled 5.3.2 just for comparison. And guess what
it now does the same thing. Preferences maybe messed up somewhere.

Can you please send along your /Library/Preferences/com.mcneel.rhinoceros.plist file so we can take a look?

An easy way to get this is by running ExportPreferences in Rhino.

Take it Look.

com.mcneel.rhinoceros.plist (144 KB)

Hi Jamol-

I tried loading your preferences file and, unfortunately, I cannot reproduce the issue that way either.

Looking back in this topic, I don’t think I see the results of booting to Safe Mode. It’s the last thing I can think to try. I’m pretty stumped on this one.

Its all good man! In the mean time I will just use the key commands that
has seem to work. Thanks for all your help.

Hey Dan-
Seems to work now that I updated to 5.4.2! Thanks for all your help.

1 Like