Viewcapturetofile not working with safe frame

So I’m trying to get a nice view in rhino to viewcapturetofile from
This is what it shows in the safe frame

but when I actually use viewcapturetofile, it gives me this. Way zoomed out from what it was.

Do the two just not work together?
Is there any way I can get it more accurate?
I’m thinking it depends on the resolution I have it set to, but I’m not sure

Hello - as it stands now, I believe the command will simply capture the entire viewport - it ignores the renderer - is that what you see?

-Pascal

You can set the resolution of the viewcapturetofile and youd think that it would just be to the top and bottom of your viewport, but it’s not. When using higher resolutions with it, it zooms way out

EX:
This is my viewport

This is what happens when I use these settings


But when I turn the resolutions up in the settings, this happens

So it’s based on resolution, but I need a higher resolution and an accurate frame, any ideas?

Hello- yeah - this does not look right to me either. I’ll see if we can fix this.

RH-68254 ViewCapture scaling

-Pascal

Make the viewport the same aspect ratio of the safe frame you want, then you’ll get much more consistent results.

When capturing the view (or rendering for that matter) the resolution is the width and the height (not the bottom and top).

Since you’re going for square captures and renders make your viewport also a 1:1 ratio. A different ratio will result in differences between what you have in the viewport and what you’re targetting.

Here with the same 1:1 ratio in the viewport and captured at 5000x5000 resolution.

The safe frame is only a visual aid, primarily used for composition (in my opinion). So change your viewport size to something that gives 1:1 ratio, position the view/camera so that you get the shot you want and you’ll be good to go.