ViewcapturetoFile Issue Rhino 6

I have been attempting to use the viewcapturetofile command in Rhino 6. However, a sort of frame appears in the middle of the screen shot as shown in the image. What is the cause of this and how can I remove it?

Many thanks!

Hi @yurkono,

Yes, I’m aware of some issues with ViewCapture + Skylight shadows. Do you think it would be possible for you to send me the model and the settings you used for doing the ViewCapture? I’d like to check if I have fixed this particular problem in my new ViewCapture code.

If you want to send the model confidentially, please use You can set the recipient e-mail to


Could you also paste the text from Rhino’s Help -> System Information...?


Rhino 6 SR7 2018-7-29 (Rhino 6, 6.7.18210.11281, Git hash:master @ f815aae129dfe2008152736625ca2dbd0036b29a)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro M1200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 411.81)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-16-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18210.11281
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.3.18250.752
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi @yurkono ,

Could you try updating Rhino 6 to the latest version (Service Release 11)?

Go to Help -> Check for Updates.... Then, click the Check now link. This will allow you to download the latest version. I think it might fix your problem.


Also here is the screenshot of my settings that I used. I actually updated Rhino 6 to the latest release not too long ago. But when I did, the option to check “Scale Drawing Thickness” disappeared. So that is why I went back to the previous version.


Do you remember if you tried the ViewCapture in SR11 despite the scale option not being there? Did the shadows look correct?

I’ve contacted two developers in regards to the missing “scale drawing thickness” option.



Yes, I still had the same issue with the viewcapture in SR11. I thought it had do with not having the ability to check “scale drawing thickness,” but that doesn’t seem to be the case.


was this ever solved? I have the same issue but the frame is horizontal in nature if yours is considered vertical in nature