Viewcapturetofile BUG - strange clipping on styles captures

I’ve being trying to export this capture that i’ve already done before but suddently, this time, it appears a weird clip that cast a shadow on top. I’ve never seen this before. Recently i upgrade the last rhino version and this didn’t happen before. This geometry is visualized through grasshopper but this clipping problem disappears when i have a geometry created inside rhino. Anyone else has this issue.

With a random sphere it doesn’t show

But without that geometry, appears

Files.
Review 02 - Asymptotic on surface.3dm (1.6 MB)
SurfaceCurvatureAnalysis - Vizualization.gh (195.9 KB)

Hello - I see that if the capture size is larger than the viewport and only if it is GH stuff, not baked - is that what you see?

https://mcneel.myjetbrains.com/youtrack/issue/RH-54116

-Pascal

1 Like

Technically what i have right now for this not to show up, it’s a small sphere positioned far away from the view that i modeled in rhino. Somehow this works but it shouldn’t be like this. But this is not about the baked geometry being seen on the viewport. The “solution” for now is to have a baked geometry living in rhino. Weird.

Hello.

Do anybody knows how this problem can be solved? This keeps appearing and it doesn’t make sense. This geometry is being visualized through grasshopper but this square shape appear everytime on rendered, artistic and artic modes



But when i add a geometry modeled in the rhino world, this clip disappears. In this case i add a sphere.



It is really annoying thing. I’ve never seen this before. Please solve this. Thank you

Hi - the issue that you reported was filed by Pascal and he posted a link to the item in the tracking system. You can check the status for this bug by following the link. This issue is currently on the list to be fixed for Rhino 7.x.

Note that you didn’t answer Pascal’s question about the capture size and so we can’t be totally sure if this is the same thing. It’s also not clear to me if you are reporting something new today or if that is still the same behavior.
-wim

1 Like

Oh my bad. I had to admit that i misunderstood his answer. Actually what he said was right, i didn’t notice that was the problem because everytime i do a capture i scale the picture 2 or 3 times, but now i try it with 1 scale (Original viewport scale) and the square clip doesn’t appear. To avoid that to happen on mayor scales, i have to bake something in the rhino world.

The pictures presented today are just to follow up with the same behavior as before.

Thanks.

Thank you for fixing this problem in the new 6.17!

Now the clip doesn’t appear. :grinning:

2 Likes

Sorry to bother you guys but i think the problem it’s not completly solved. It still appears but it’s less noticeble.

I didn’t see it last time but if you notice the last picture i sent you, the clip almost shows but without the depth shawdow it used to appear and make the square clip stand out.

Artic mode

Artic mode (different resolution but you can see how the line goes along half the picture and how the shadow suddendly clips)

Artistic mode (doesn’t show)

Rendered mode

Thank you!