ViewCaptureToClipboard with transparent background

Hi, I’m trying to get a rendered image by ViewCaptureToClipboard as an alternative option of opening a separate rendering window for Cycle render. While both produce the same images, by far, I did not manage to get an image with an alpha channel. When I turn “transparent background” on, the background image is altered with a solid black color. What I’m actually doing is to paste the image to Photoshop by hitting “Ctrl+V”, so there is a chance the alpha channel is actually there in the clipboard intact, but anyway I could not find a way to get an image with a transparent background. Is there any hint on this?

Thank you!

Perhaps a display mode can solve this for you quickly.

I’ve created a display mode called Alpha (seen below on the right side of the image).

  • All geometry has a white material
  • All lighting is disabled
  • Background is set to black
  • All curves/clipping planes/annotations etc. have been turned off

Alpha.ini (11.4 KB)

So the workflow would be to make 2 captures, one with your desired display mode, then an additional with the Alpha display mode. Paste them both in Photoshop.

1 Like

Hi, thanks! This is helpful for many people.

1 Like

This works just fine as far as I can tell. With Rhino 7.16 at least I get this when creating new image from clipboard in GIMP:

From this Rhino document

And with shadows-only ground plane enabled I get

A short screen recording to show how I got that:

Hi, just found this, saying it is a well-known bug of the windows version of Photoshop… :stuck_out_tongue:


Time to switch to GIMP then (:

meh. :stuck_out_tongue:

Affinity products are absolutely fanatstic, and a great price point too :+1: