View Settings Bug - wont stick

On my two computers I’m getting the same bug. If I click off an option in the Display tab or turn it off in the settings it reverts almost immediately. I.e., the default is reset if I try to change anything. I see the change briefly but when I move the mouse or otherwise it resets. The only reasonable source of error I can think is I’ve imported my “shaded” view mode settings from RH5 on both computers. The settings from that have reset too but may have done so during an update and not from this bug. I don’t have a clean install to test this on but here it is if perhaps that’s the common link. It changes lights and naked edge weights.

Shaded .ini (12.3 KB)

Yep, thanks - actually this is a longstanding bug in the WIP… we are aware of it- I don’t know where we are with fixing it.




I was having the same issue like this:

After installing the latest WIP build, I shut it down and deleted the settings folder AppData/Roaming/McNeel/Rhinoceros/6.0/Settings, and also everything in \AppData\Local\McNeel\Rhinoceros\temp. On restarting the WIP it recreated the Settings folder, and (I think I had to repeat this more than once) the problem went away.

It could easily have been coincidence, but it worked for me. Probably unrelated, but another thing I have been seeing is when I close the WIP I get a pop-up saying it can’t save the .rui because the file is in use, but then it saves it anyway.


yep that’s the thing. I’ll try deleting the settings folder unless someone else thinks its dangerous.—dangerous being a relative term

Take the conservative approach and rename it “SettingsOLD” instead of deleting, can always restore it if necessary then.

Just tried – No change. Tried a few times.