VA Styles wizard - unexpected Rhino shut down

Hi,
Rhino shuts down while editing VA Styles. No crash report, no error. From time to time I had problems like that in the past but now it happens all the time.

It’s pretty critical because it happens when I want to update my VA Style which I was working on for some time.

Very rarely I can go through the whole VA Style update wizard process without crash.

Sometimes Rhino shuts down at the very start of the VA Style reload process, sometimes at the end.

I’m using Rhino 7 and this problem occurs in VA 2.11.3 and 2.12

VA tween fill 2.gh (45.9 KB)
VA Style Reload Problem.3dm (664.3 KB)

Hi @Czaja,

I’m unable to reproduce the crash. I tried several times, using Rhino 7 SR10 and VisualARQ 2.11 and 2.12.

I don’t have any other third-party plugin enabled, and I only have the “Pufferfish 3-0” Grasshopper add-on (as required by your style definition).

Can you please try to disable all third-party plug-ins except “Tibidabo” and “VisualARQ”. Also please, move all files from the “C:\Users%USER_NAME%\AppData\Roaming\Grasshopper\Libraries” folder to a different folder (except Putterfish, of course).

Thanks,

Enric

  1. In the middle of the night, a new update come out and I updated my Rhino to the 7.12.21299 and I couldn’t reproduce this behavior anymore.

  2. I rolled back to the Rhino 7.12.21292 and VA 2.11.4 had this issue three times in a row. (Once I reloaded the style, and wanted to do it again, and then crash happened)

  3. Disabled plugins and moved everything as you asked me. (Still, some GH plugins remained because they were installed by Package Manager). - No crashes.

  4. Loaded all the Rhino and GH plugins back - just to check if this might be plugin-related. And surprisingly, no crashes.

  5. Updated Rhino back to 7.12.21299 - no crashes, updated VA to 2.12.0.15233 - no crashes.

TL;DR
Sorry, I tried but I don’t know how to reproduce these problems in a consistent manner.
But they are real and I had them in the past with completely different VA Styles.