V8 screws up Cloud Zoo - Needs fixing ASAP

The Cloud Zoo was screwed up by V8 installation. Others have previously mentioned problems without anyone from McNeel appearing to notice.

I installed V8 on October 31. Since then it is no longer possible to have two versions of Rhino open simultaneously. I can have multiple instances of the same version open simultaneously, but not instances of different versions open simultaneously.

When I try to open two different versions of Rhino this panel appears:

If I click Yes the panel closes and pops up again,

If I click No the panel closes the already open version of Rhino.

When V8 Beta was installed the Cloud Zoo worked as expected and I could have multiple versions of Rhino open.


This could be an unmentioned change in policy if your V8 was an upgrade from V7.
If I recall, a V7 upgrade license was allowed to run V6 simultaneously because of V6 plugin compatibility issues.

@brian: am I imagining this about V6/V7? Is the V8 thing a bug or policy change?

If your installation is say a single V6 license plus V7 and V8 upgrades, you should be able to run any combo of Rhino versions with as many instances as you want on the same machine. If something else is happening, then it’s a bug in the system somewhere.

1 Like

That is the situation.

That is what I used to be able to do, but since installing V8 can no longer do.

There is a bug somewhere.

Hi David -

That works fine here.
Which versions of Rhino 7 and 8 are you running?

Hmm… local licenses, or Cloud Zoo?

RH-78061 Can’t run V8 and V7 at the same time

To expand on the issue slightly: If you start R7 then R8, or you start R8 then R7 you get the problem.

But as a workaround, if you say “No” to continue using whichever one you opened first it will close and you can then re-open it without the error appearing again. This allows you to run R7 and R8 simultaneously.


As a further expansion: the bug applies to R6 and R8 as well.

Cloud Zoo as in the thread subject.

Also occurs with V6 and V7 without V8 involved, other than having been installed.

Thanks for reporting this. We’re looking into it now. The bug is likely in Cloud Zoo itself, so once we sort it out, it should just start working for you. We’ll let you know how it goes.

It even asks if you want to keep running R8 even though it isn’t open! But at least you can say no to R8 and keep the other two running…

I think we need someone to check all the earlier versions. Wasn’t @Helvetosaur running R1 the other day…

If it’s a Cloud Zoo problem then it should only involve Rhino 6, 7 and 8. Rhino 5 and earlier do not use the Cloud Zoo.

Having installed R8 on my laptop, I downloaded and installed on my desktop. R8 identified the Cloud Zoo licence from the first install.

I then got into a seemingly endless loop of messages saying “Your licence has been in use on [name of the desktop, not the laptop], do you want to keep using Rhino 7 here?” and “Your licence has been in use on [name of the desktop, not the laptop], do you want to keep using Rhino 8 here?”

Why R7 is involved I don’t know. Why Rhino is trying to transfer the licence from the desktop to itself I don’t know. Had to answer “No” to break the loop. After a reboot, things were back to normal.

Unfortunately this reoccurs whenever you run another version of Rhino alongside R8. Changing category from Papercuts to Bug.

Any follow up in this similar thread, please:

For troubleshooting purposes:

  1. I have not experienced this problem
  2. Flow was: install and try evaluation (running 8 only). Buy license upgrade. Proceed as normal, able to run either/both. I ran V8 first and that was when I got the multi-step trip through the cloud zoo and website logins.
  3. I have release day V8 and release candidate Version 7 SR35
    (7.35.23280.19001, 2023-10-07). Windows 11, all patches.
  4. When I installed and opened 8, I had a bit of an extended trip through the cloud zoo prompts on the website for licenses, including a notice that I was removing a license. I did not get an already-using-on-computer-x type prompt. This is my first major version update so I don’t know what’s normal.

Note (if this helps any), this is what I see in the notifications panel in Rhino 8 when I start it…

And this when I start V7:


License obtained for both Rhino 7 and 8? In both Rhino 7 and Rhino 8?

9th Nov.: looks like there has been a change “in the cloud” (now get an unable to access server message) - but it hasn’t fixed the problem.