V6 tabs display bug?

tabs
rhino6

(Przemysław Doliwa) #1

I think vertical tabs shouldn’t look like that - in v5 tabs looks properly in v6 text is somehow weirdly condensed and not centered on the tab?

Oh and v6 tabs are somehow too big to my taste and there’s no longer option for choosing tab size …

Also in filter there are unnecessary spaces between options (upper is in v6)
filter_spaces

And one more question is there any way to change text size inside tabs - for eg in view tab - v5 sizes were more compact and more pleasing in my opinion.

EDIT: I know filter spaces are leaved for verts/edges/faces if subselection is on but is it that hard to move checkboxes after on/off? I know that coding ui isnt most pleasent work to do but all this little things matter how user feel inside program - my feelings in case of v5 were - it’s rock solid - in case of v6 - hmmm something went wrong here…


(Przemysław Doliwa) #2

I’ve noticed also other bug in ui when filter and osnap is positioned one after another osnap on start isn’t present

I’ve noticed Osnap - button/ribbon don’t highlight each time sometimes it does sometimes not at all - filter button/ribbon don’t highlight at all

Newest SR1 RC doesnt change a thing in this matter


#3

Yep, known bug, don’t know when it will get fixed… --Mitch


(Przemysław Doliwa) #4

@pascal i know this could be treated as cosmetics but i feel this should be somehow solved i also don’t know why v6 sizes are that different? why everything feels oversized (including lines in the viewport)? Is there any special reason for that?


(Przemysław Doliwa) #5

Here again i have that feeling

OneView Labels aren’t perfectly centered some of them are some of them are higher.

Tooltip holders have too much space on bottom // or they aren’t positioned properly

There could be option to show labels only in case of perspective camera, it could go even further (it would be more complicated but on right click instant change to selected side view ( of course only in case of perspective cam - i know it can be changed from left label but it requires more clicks each time )


(Wim Dekeyser) #6

Which version are you running?
As of SR1, those labels should only be visible in perspective views.
ref.: RH-42717


(Przemysław Doliwa) #7

I’ve updated to sr2 rc1. Yes now it is in perspective viewport but labels are still floating up and down sometimes one px up sometime one down …

labels_sr2

Tabs are still broken and osnap + filter is also still broken.


#8

I cannot see this bug in 6.1 commercial version (2018-2-6).


(Przemysław Doliwa) #9

Take a look on right and take a look on first post where are v5 captured

v6:

besides all tabs are noticeably bigger than in v5

v5:

@Andrew_Nowicki could you provide screenshot and which win ver you are using ? (i mean here 1703 or 1709?) Maybe win screws this up here…


(Przemysław Doliwa) #10

@pascal Would you mind add this small cosmetic issue on youtrack? I mean at least vertical panels labels?


(Pascal Golay) #11

Hello - thanks, I’ll get that on the pile…

https://mcneel.myjetbrains.com/youtrack/issue/RH-44562

-Pascal


(Przemysław Doliwa) #12

Thank you Pascal!


(Przemysław Doliwa) #13

@pascal tabs are fixed thanks for that but im always missing osnap bar at start V6 tabs display bug?

Would you mind ? Its so frustrating to keep turning it on and on and on each time :confused:

To be clear this could be tricky bug cause sometimes it works and after few times suddenly next few runs don’t show again osnap bar at start.


(Wim Dekeyser) #14

RH-43515 is fixed and will get to you in a SR RC soon.