V6 Rhinoscriptsyntax help is still not helpful

rhinoscriptsyntax

#1

So, I wanted to see if rs.MeshObjects had by any chance been added to V6. It hasn’t unfortunately, but that’s a different subject. I saw it was not in the left sidebar in the python editor, but I wanted to make sure anyway, so I thought I would check the rs help page:

http://developer.rhino3d.com/api/RhinoScriptSyntax/

There, in the search box, I typed “meshobject”. I got the following:

(There’s tons more pages…)

That is not extremely helpful (to say the least), what might have been more helpful is simply a reported result that that entry does not exist in http://developer.rhino3d.com/api/RhinoScriptSyntax/ - which would have confirmed its non-existence - and perhaps an offer to extend the search to the rest of the site.

So, then I decided to search for a method I know exists - lets say something really common like GetObject.
I got this:

Again, nothing that got me anywhere near the rhinoscriptsyntax method help topic. Searching for GetObject(), rs.GetObject, rhinoscriptsyntax.GetObject didn’t help either.

OK, next I pick out something from the left hand “modules” column, say layer, and click on the LayerName entry in the right column. That works, I get this:

Oh, actually, I wanted LayerNames, not LayerName - so I click on that one after. I get this:

Where is the entry? It’s scrolled up off the top of the page…

You can continue clicking on entries in the right column and mostly they open off-screen. Occasionally you see a piece of them just at the top.

C’mon guys… this is not really McNeel quality. It just isnt.


(Dale Fugier) #2

Hi @Helvetosaur,

The help file will be back in SR3. Hopefully that will help.

– Dale


#4

Yes, that will certainly help me. However, the web page scroll problem above at least should be fixed, and I still think that for the users of the online Help that the search on that page should be limited (or at least prioritized) to the rhinoscriptsyntax section.

Thanks, --Mitch


(Alain Cormier) #5

It looks like the scroll problem started to occur after some javascript libraries were updated on the site and it’s now fixed.

Search for the whole site, not just rhinoscriptsyntax, has to be improved but in the meantime you can search the rss content by clicking the ‘+’ symbol after the word ‘modules’ near the top and that will expand all the content (it takes a few seconds). You can then find what you need by using your browser’s search box (ctrl + f).


#6

Yeah, I tried that before, it really doesn’t work well. First, someone needs to know what the little “+” means. Next, it takes forever to load - not just a few seconds and you have no idea if anything is really happening in that time. Normally you think, OK, that doesn’t do anything I’ll just get out of here.

If you do let it go, and you scroll down after the first few pages load, you get a blank page and the browser window starts flashing trying to catch up. If you let it all load and you use Ctrl+F and a common function like GetObject, you get several hundred matches because it’s used in lots of the samples.

So, no, this doesn’t work for me… :frowning_face:


(Alain Cormier) #7

I hear you. Just trying to give you options until we fix it.