V6: Rectangular lights and Gimball bug

unhandled

#1

Whenever I make a new rectangular light the Gimball is allways struggeling to find the center.
You should be able to reproduce it instantly as I don’t think I have any special settings activated.


(Pascal Golay) #2

Hi Jorgen - I’m not sure I follow – here, if I select a rectangular light, new or not, gumball appears at the center instantly… I guess I need the blow-by-blow, for dummies.

-Pascal


#3

Strange thing… It struggles every single time here. And I even did a uninstall before installing the latest build.
Here top view and perspective is OK:

image

But if I select it in Back or Right (Had to use Back on this project) then the Gumball is off by a lot. The light was just created to illustrate:
image

If I select in Back or Right then the gumball is at different locations:
image

Oh… I had ALIGN TO CPLANE and not ALIGN TO WORLD. and that is probably a sticky command (that nobody uses) So take a look and see if you can reproduce the oddity, because it obviously is a strange behaviour.
Cheers!


(Pascal Golay) #4

Hi Jorgen -

I cannot reproduce this so far… regardless of Gumball alignment (who you callin’ ‘nobody’??) Does this happen in a new empty file? If so can you make a light and post the file?

thanks,
-Pascal


#5

:smiley: I was just referring to the C-plane alignment option, based on the “fact” that it only happens with that option, and that only I see it :wink: I’ll see if I can send you a file.


#6

Yeah, here it happens on every file, new or old, on both machines I have tested, so it makes no sense in sending a file.

It’s consisten in it’s location related to the c-plane ( I use the default 4 view setup) and if I move the cplane origin then the gumball get’s a new location too. (again it is consistent to that new location…) Odd stuff…

I experienced this earlier too and just expected it to be ironed out. And both machines had Rhino Beta uninstalled prior to having the release version of V6 installed.


(Pascal Golay) #7

Hi Jorgen - are you adding the lights ‘by hand’ using the RectangularLight command? Not a macro or script or something? Actually, it would not hurt to send a file - make a light, actually move it with its goofy gumball, to set the Gumball frame and then save it - thanks.

-Pascal


#8

Hi Pascal,
I add them by hand, that’s why I was so sure I was not alone in seeing this :slight_smile:
And the strange thing is that I see this on my third computer as well.

Here is a file.

Rectangular light.3dm (23.9 KB)


(Pascal Golay) #9

Hi Jorgen - thanks - it looks correct here… does it make any difference if you start Rhino in Safe Mode?

-Pascal


#10

No change, but as you can see the offset is related to the center of the rectangluar light, but on a different c-plane so some sort of conversion error is going on…

And if I move it and reselect it:


(Mikko Oksanen) #12

@pascal, yeah, I see it. It happens in views with CPlane other than the world XY plane. I just fixed it so it should work in a near future build.