V6 Goal: Display Performance


(Steve Baer) #222

@jeff, @DavidEranen, and I have been rewriting the OpenGL display over the last few months to allow Rhino to perform all of it’s drawing at different specific ‘versions’ of OpenGL. I’ll write up a post about this once we have this code in your hands that you can use (hopefully in a few weeks). Sorry for being so quiet about this lately; there hasn’t been much to discuss while this code is still not running on your Rhino.


Detail from a draft analysis (latest build):

Rhino 6 SR0 2016-10-11 (Public Build, 6.0.16285.11581, Git hash:6.0.16285.11581 in branch n/a)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)

GeForce GT 650M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 373.06)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 10-1-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\SolidTools.rhp “SolidTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a

It does look pretty groovy though :slight_smile:

(Steve Baer) #224

I just fixed that today. We should be releasing a build with this fix tomorrow.

Raytraced: GTX 10xx testing requested

Hi Steve, is it possible to bring back the speed of displayed meshes?

(Steve Baer) #226

The plan has always been to improve the display speed for all objects. Sorry if I wasn’t clear enough about that.


Fine, the current release let me doubt it could be not so. I don’t expected a step back.

Good luck.

(Steve Baer) #228

The display code is basically like rebuilding a house while you still live inside of it. In the long run it is going to be much better, but you might have to sleep in the garage for a little while. Steps back in display performance are to be expected during this phase which is why I haven’t asked people to do much performance testing lately.

(Willem Derks) #229

I’m all set up:



So I will patient and wait for the next official performance test round. I’m very curious. For me a better display performance is the most important reason for an upgrade to a next version.


Hi guys,

Not sure if this has been highlighted anywhere else but…
when I am trying to chnage antialising mode in OpenGL - no change happens. From None to 8x I don’t see any difference.

Any hint - why?


(David Rutten) #232

Can you see if a difference if you only draw meshes? Ie. make sure that there are no lines or curves visible anywhere.


Forgot to mention that I checked only Curve objects before.
Actually now I did a test in addition with Mesh and Surface objects (testing only Wireframe mode).

Difference can be seen only for Mesh object.
Edges of surface have similar behaviour as curves (no change) when switching between antialising modes.

As it seems - it shows 8x by default.


And another bug: when adding an object (curve, surface or anything else) - I see that Properties window doesn’t show any assignments (layer, color, isocurve density, etc…)

Guess it is a bug or?


(David Rutten) #235

The curve anti-aliasing thing is not a bug, they are now drawn anti-aliased from the start using open-gl shaders. It allows us to get higher quality curves without super-sampling.

The second thing may be a bug. The properties window should always show the properties of the current selection set. If your new object isn’t selected, then the properties window should not include it.



Obviously I am talking about selected object.


Ok. But the difference between edges of mesh and surface when switching a-a mode is not normal - right?



I don’t get the ambient color working for the rendered mode. I disabled shadows and “use advance GPU” lighting. Any ideas? Is it a bug?



It works now but can’t delete the last post.


Oooops, I was confused between my open rhino tasks. So, at Rhino 6 the ambient color doesn’t work.


Hi Holo,

How can you control which video card to be used in Rhino?