V-Ray Water Caustics not possible?

Hi all,

Today I wanted to try some caustics effects inside Rhino with V-Ray but I was not able to achieve the effect.

I know it is possible because in SketchUp they get very nice results.

I replicated both these methods, essentially the same, but no luck.

A) V-ray 5 Tutorial : Realistic Pool Water - YouTube
B) Vray 4.2 For Sketchup Water Caustics - YouTube

I did enable Photo Mapped Caustics under GI Caustics in settings.
I did disable ‘Affect Shadows’ under Refraction settings.
I did increase the Caustics Subdivisions and Emit Radius in Sun settings.



I have also played with Caustics Settings quite a lot and no luck.
caustics.zip (11.2 MB)

Any ideas?

Did you tried an other light source as a first test?

1 Like

You mean besides the sun? I tried a directional light too and no luck.

Caustics are not supported in v-ray GPU

Have you tried CPU instead?

1 Like

Yup! I used the default, CPU

I would try a spot light. It focus the photons to a limit area. Maybe something is wrong with the emit radius of sun/dirlight.

I think it simply does not work in V Ray for Rhino for some reason. Have you been able to create caustics?

I don’t use caustic often and I have no experience to setup it. So, I did a test where I’m sure I have the best control … per spot light … see screenshot … and so we can say: the caustic system works.

Next test - dir light. … it has no caustic options anymore. I reported it as a bug now.

Next test - the Rhino sun. Your set radius of 800 is much to large for the scene. I set it to 80 (the pool length is only 15) and it works too. :slight_smile:


Oh okay, so Sun + Spotlight seems to work. Spotlight alone as well. Did you manage to make it work with only the sun?

I don’t used sun and spot light at the same time, so yes, only the sun works.

You need to understand the radius parameter - the photons are shot within this range. If you use a to large radius than you need more photons to get a visible effect. So, best you use a radius which match the pool size.

Another small quirk that is good to know.
The sun in fact has a position. That position is typically at location 0,0,0. Since its rays are parallel and infinite it doesn’t really matter for shadows and effects. However the location matters for the photon emission.
If the caustics are ON, the sun position is moved along the rays direction, so that it is just outside the bounding sphere of the scene. This ensures that any caustics effects are not cut out on surfaces “behind” the sun.
When you set up your emit radius, you shall consider a number large enough to take account for that.
If you like you can export a vrscene file and see where exactly the sun position is (= the photon source)


Thank you for all the recommendations guys,

For those interested I was able to achieve it by copying the settings in this video. (the same I linked in OP) Using just the Rhino Sun, but changing the emit radius of the sun to 80 like @Micha said.

Here is the before and after: