V-Ray for Rhino 5 not using 100% CPU

I have just built a new PC and when rendering using V-Ray in Rhino it is significantly slower than my old PC… Which doesn’t make sense since the new PC spec wise is better in every way.

AMD (Old PC)
Processor: AMD FX-8150 Zambezi 8-Core 3.6GHz Socket AM3+
Memory: G.SKILL Ripjaws X Series 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 1600
Video Card: EVGA GeForce GTX 560 Ti (Fermi) 2GB 256-Bit GDDR5
OS: Windows 7

Intel (New PC)
Processor: Intel Core i7-4790K Devil’s Canyon Quad-Core 4.0GHz LGA 1150 (Hyperthreaded)
Memory: G.SKILL TridentX Series 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 2400
Video Card: MSI GAMING GeForce GTX 750 Ti 2GB 128-Bit GDDR5
OS: Windows 8.1

The AMD processor will render using 100% of the cpu. My test rendering finished ~8 min. The Intel processor only uses ~20% of the CPU and finishes in ~30 min. I’ve posted an album with all of my V-Ray settings shown. Both PC’s are running V-Ray Version 2.00.02. I have a feeling that my V-Ray setting are optimized for my AMD processor and not for my new Intel. Could anyone help me tweak the settings in order to see a boost in performance from the Intel processor? Thanks!

Album: http://imgur.com/a/hmHO5#9

CPU Comparison: http://cpuboss.com/cpus/Intel-Core-i7-4790K-vs-AMD-FX-8150

All the options looks correct.
Does your new computer works in multithread with other softwares or not?

Maybe, just maybe, the option to have the multithread is switched off (in the bios).