Updates and languages... $#@%$!


#1

So already the last update to SR5 (not release candidate) screwed the Rhino help on my workstation (as per previous post)… Installing SR6 Release Candidate seemed to have fixed it - the help is back - but guess what… it sh–canned my languages. :rage: There are no longer any entries for language pack installs in Control Panel>Programs - like they were never installed (should be both French and German) - and of course no languages other than English to choose from in the dropdown inside Rhino.

There are still folders for all 3 languages in
C:\Users\<me>\AppData\Roaming\McNeel\Rhinoceros\5.0\Localization
(which proves that they were once installed), but only en-US in
C:\Users\<me>\AppData\Local\McNeel\Rhinoceros\5.0\Localization

It gets better… Last evening, preparing for my course this morning, when I went to close Rhino, I noticed there was a service release waiting to be installed (SR6 RC1), and without thinking, I let it… This morning, open Rhino just before the course, open my French Rhino scheme, and odd - the toolbars were in French, but the menus were in English… The language choices were there inside Rhino and it was set to French, but no way to get the menus, etc in French. Essentially it was in English, but it looaded the workspace in French. Checked to see if the language packs were installed, they were, but got an error message if I tried to “repair” the installation.

I thought it would be good to download the SR6 RC1 for French and try to install, but I have no idea how to access it, as it’s not up on the website… So in desperation tried a system restore to yesterday before SR6 RC1 was installed. Bad idea… very bad idea… :confounded: After the restore, opened Rhino and… no toolbars. OK, let’s go to Toolbar Layout and try to reload the .rui… Error: "cannot run toolbar layout, the toolbar plug-in is not installed and cannot be loaded?.. Go to plug-ins and it IS checked as if loaded. NO WAY to get toolbars to load…

Now panic is starting to set in, now no language (need French for my class) - of course the system restore didn’t fix that - AND no toolbars. Finally, I had to uninstall Rhino completely, reinstall from disc (had it with me and didn’t have time to download the whole thing) find the service pack and install that - and fortunately that got me back up and running. :cold_sweat:

Needless to say it was not a very pleasant way to start the day (being nice here), and especially that this is not the first time that Rhino service releases etc. have messed up my multi language installations.

Right now my laptop is telling me that SR6 RC is available again, and I’m not sure I really want to try again; and my workstation is devoid of other languages altogether and probably also needs a reinstall. Not a particularly happy camper here…

–Mitch


SR 6 C2 problem with language
(Margaret Becker) #2

This one is for @brian, I think.


#3

Yep. I now checked my home workstation after installing SR6 and it has the same problem as my laptop - menus etc are in English, toolbars are in French, but the languages are definitely gone, although Rhino seems to think they are still there. Well, I’m not going to try the system restore trick…

–Mitch


(Brian Gillespie) #4

Mitch,

I’m sorry to screw up your system so badly with this service release. I’m afraid the cause of all of this was something I changed with you specifically in mind: I wanted to make it possible to add languages to Rhino after the fact, and you can do that now. But clearly updating an older installation that had multiple languages installed isn’t working at all.

I’ve added an SR6 stop-ship bug to investigate and fix this. I plan to have it fixed before SR6 RC2 comes out.


#5

OK, I understand the intention and thank you for the effort, even if it didn’t work right… Is there any way to post install them on the systems that are messed up (instead of uninstalling and re-installing)?

Thanks,
–Mitch


(Brian Gillespie) #6

Yes. I’ll get a download link together for the language packs so you can give it a try.

In the mean time, here are the current ones:

French, German, English, Italian - let me know if you need other languages.


SR 6 C2 problem with language
#7

Brilliant, installing French and German packs from your links fixed my workstation! Will try later with the laptop.

Cheers and thanks,
–Mitch


#8

Well, unfortunately, no success with my home workstation… :disappointed:

On my main work workstation, the languages had been completely wiped out, so installing them fixed the problem. My home workstation is different - it still has them installed, but they have partially stopped working as posted above - even though the scheme is supposed to be in French according to options, the menus etc. are in English. Trying to reinstall the language pack from your link doesn’t fix those symptoms - I’m assuming that it is installed, but something is corrupted somewhere… The registry entry

HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: FRDefault\Options\AppearanceSettings\language_identifier

does indicate 1036 (French). So, I guess I’m looking at an uninstall/reinstall anyway. Some funny stuff in Options: Toolbars, Updates and Licenses are in French, I assume these are plug-ins…

–Mitch


(Brian Gillespie) #9

I’ve been chewing on this problem for several days. I understand the cause, and a solution is starting to crystallize in my mind. I hope to have something for the next RC.


Language issue
#10

I have installed

rh50Release_x64_en-us_5.7.31105.12495.msi
rh50Release_x86_ko-kr_5.7.31105.12495.msi
and
rh50_language-pack_en-us_5.7.31105.12495.msi
rh50_language-pack_ko-kr_5.7.31105.12495.msi

But, I could not update not only language-pack_ko-kr but also Rhinoceros 5.0 Help Media.

Do you know the reason?


#11

Oops. no reply.


(Mikolaj Jarski) #12

Hi @brian,
After updating to sr7 rc (5.7.31113.14095, 2013-11-13) I lost English interface (only Polish is left).
How can I repair it now (should I use link from the post above, 24 Sep)? Or is it reasonable to start from scratch?


(Mikolaj Jarski) #13

So, I started from scratch - removed Rhino, downloaded and installed rh50_en-us_5.6.31028.18305. English is back. How can I add other languages now?


#14

At the moment of installation, you didn’t have language choices? If not, you need to go here and download and install them…

–Mitch


(Mikolaj Jarski) #15

Thanks Mitch, I didn’t know there was a public site with language packs.

No. I downloaded the installer from http://www.rhino3d.com/download/rhino/5.0/latest where I could pick only one language, no more options during installation (but it is also a smaller file - 449 MB, instead of full 1.1 GB, as it used to be before).


#16

You can get the full language installers where you went, you have the choice after you enter your e-mail… Hmm, maybe they all install only one language, you’re right…