Update broke the multiplication component

I just updated to Rhino WIP 2017-Jun-21 and found some issues in grasshopper:

–Multiplication component now functions as an addition component.
–Previous multiplication component now says “old”.

–Numbers in panels are no longer recognized when fed into components requiring numbers (seen as text).

I’m hoping the multiplication component being changed to “old” is unintentional. Otherwise I’m not looking forward to going in and changing every one of those components out in some of my more complex definitions. I would be interested to know how denoting a component as OLD is meant to work. I first encountered that when I was trying to get out of date examples for plug-ins to work. It seemed as thought in some cases old components still work, and in others they don’t.

And in regards to the Panel Component issue. I doubt it would have been considered a “best practice” to use the Panel to feed numbers into a component, but I sometimes like that approach for input that I am not likely to change, but where seeing it clearly helps remind me of how the algorithm is meant to work in that segment. If anyone has another way to suggest I would be open to it. I do use sliders, and I recently started to use the “values” component for certain situations.

Oops, I’m on it. The change to ‘old’ is intentional, because I wrote a new multiplication component that replaces it. The old one still works as before though, so you can continue to use it. I indeed forgot to add automatic text->value conversions in the new component logic, and obviously the addition/multiplication mix up is a serious bug. I’ll upload a fixed GHA file here asap so your Grasshopper becomes functional again.

Ok, fixed. New GHA coming soon.

Snap…I’ve spent a good hour yesterday adding number parameter to convert text to numbers in my definition… I thought this was intentional :joy:

MathComponents.zip (270.3 KB)

Please find the MathComponents.gha on your system for Grasshopper in Rhino WIP (probably somewhere like C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\Components\) and change the extension to something meaningless. Then unzip the above file into the same folder. This needs to be done while Rhino is not running.

WOW! I am completely amazed at how quickly you made time to resolve those issues. Thank you so much! I am deeply involved in using Grasshopper for a body of artwork I am making this summer, so any slowdown I can avoid really means a lot to me. I have nearly worked through the night at this point, so I will have to try out the new components tomorrow. Thanks!

1 Like