Unusual surfaces from a STEP file

unhandled

#1

Can anyone explain the unusual surfaces obtained from a STEP file in the attached?
First of all the file is large even though there are just a few surfaces.
Secondly, when the surfaces are selected a weird selection outline in shown.
If you try to duplicate the surface borders you also get unexpected results, including a center circle that is unexpected.
This isn’t anything critical, I just am curious what is going on.
Thank you
MSweird shape.3dm (3.9 MB)


(Pascal Golay) #2

Hi MSavage - send us the Step file if you can, I’ll take a look.

-Pascal


#3

The display issue is due to bad trim boundaries that result in the 2 bad objects displaying the part that is supposed to be trimmed off instead of the part that is supposed to be showing. This is not uncommon with a sphere or torus in a STEP file. Happens fairly often.

I think this is what the part is supposed to look like
not_weird.3dm (99.0 KB)

I don’t know what makes the file so large. I used export selected to get the above small file.


#4

I think there is always problem when exported objects from assembly programs like solidworks, catia, inventor… Because rhino understands blocks differently, when you export 1 object there is so many objects attached to that 1 object. I try it to get out from yours file all that hidden objects. Check always your blocks before you export. Look inside this file … weird shape_blockProblem.3dm (3.8 MB)


#5

Interesting that all that was hidden.
But I can’t seem to determine how to expose the hidden items from what I thought was simplified surfaces.
Can you explain how to reveal those hidden items that explain the file size?

MS


#6

Go to Edit => Block => Block Manager , the hidden objects is there you can export all objects separate.


#7

Hello everyone! I have the same problem too! (and it’s really critical to me)

Normally, my workflow consist in modelling 3D pieces in Inventor, then export it to Rhino in STEP file, but when I open my STEP file on Rhino, it looks really weird: with multiple surfaces that do not correspond to the original model. Attached both images. Same has MSavage share.

I’ve tried everything: reinstalling the software, export in 203, 214 and 242 STEP file formats, I have the latest update from Autodesk Inventor 2018 and Rhino 5, I also download the Rhino 6 trial version to see what happen and still the same problem (with less surfaces, but still multiple geometries).

It is frustrating, because in the past this was not a problem to me and if that happened, it was with few surfaces or none, or just explode the block, with no problem. Now I have a loooot of surfaces to clean. Now is more often and hard to join and clean up the model.

Could you please help me with this issue? Thanks in advance!!!


(Pascal Golay) #8

Hello - please try the V6 SR2 release due out later today and see if that is better - you can also send us the step file (www.rhino3d.com/upload) to my attention, and I’ll take a look.

-Pascal


#9

Hello Pascal! Thank you so much for your help, I’ve attached the RAR files.

Just to recap:

I attached again all the files to you, with better image references. Actually I have to use Rhino 5 (I use VRay there), but I have the trial version just to make the tests.

In rhino 6 is impossible to join the surfaces, but in Rhino 5 if I selected one by one the bad surfaces and I delete them, I can re-join the geometry and the result is a closed good 3d polysurface , it takes time and patience.

My thought (in my ignorance) is maybe is a bug that have some conflict recognizing some geometries (especially fillets with radius).

Also attached other step file with the same problem (AKARI)

I hope you can help me with this issue!


(Pascal Golay) #10

Hello - thanks, as far as I can see Rhino 6 SR2 (6.2, the latest as of yesterday) opens these files correctly.

-Pascal


#11

I will try installing it, Could you please send me a link to download the SR2 trial?

I already bought the Rhino 5 and Vray, but if rhino 6 solves the problem, we will buy this license too.

Besides: Any updates about VRay for Rhino 6?

Again: thanks for your help on this Pascal! :slight_smile:


(Pascal Golay) #12

Hello - the current evaluation installer is here -

https://www.rhino3d.com/download/rhino-for-windows/6/evaluation

-Pascal


#13

This is still happening. STEP can’t handle the revolved surface. The nut that’s intact was imported directly as a Solidworks part - no problem. Too bad we can’t import entire assemblies that way. Too many configurations/duplicate parts.

NUT.3dm (585.3 KB)