Exporting to Step is giving me different surfaces

Hi. I am trying to export a polysurface to Step. The cnc providers rightly pointed out that the Step file resulted in a different outcome:

On the left, the Step file was re-imported into Rhino. You can appreciate the inconsistencies compared to the native Rhino polysurface.

What could it be? I tried with IGES, and it works perfectly.

Thank you

1 Like

Hi Bruno -

Please provide both the output from the Rhino SystemInfo command and a 3dm file that we can use to check this issue.

1 Like

This is a common outcome of migrating from one program to another. Don’t worry, it’s kinda expected and perfectly resolvable.

It’s really noticeable when migrating from parasolid geometry into nurbs, but can certainly happen the other way around or even especially when dealing with how other programs interpret the iges or step formats.

This is why I usually avoid things like degree 5 geometry and modified control point weights etc., cause other programs aren’t as advanced as Rhino :slightly_smiling_face:

Sometimes I’ll use .3dm format if other programs can interpret that better than the iges/step, but it’s give or take and doesn’t always work, depending on the geometry.

Thank you,
I am sharing the three dm files and the system info with you.
forum.3dm (2.5 MB)
Rhino 8 SR0 2023-10-31 (Rhino 8, 8…txt (2.5 KB)

Let me know if there are any other things I can help with to sort this out.

1 Like

This is what I suspected:

So, imo, part of what could be happening is the other program’s (CAM) ‘interpretation’ of the hidden underlying geometry. Basically the CNC operator isn’t getting the CAM software to read the ‘trimmed’ data correctly – from what I see.

There’s a few factors to consider, of how the geometry is being ‘inported’/‘inserted’/‘merged’ etc. via particular formats and ‘rules’ upon the softwares interpretation of said .step.

There’s about a dozen things to choose from of how to get the CAM to interpret this properly – imo.

On Rhino’s end, it’s possible you could try different format output, or even slightly altering the geomtery to get the CAM to have an easier time with the data.

‘Shrinking’ the trimmed surfaces might help, for example.

It all depends how you’d like to go about it. If the CAM operators had the ability to use .3dm format, then that might help too.

It all depends. It’s also possible their ‘interpretation’ settings for .step files might need an adjustment of how to deal with the surfaces, etc.

Technically, I’d recommend doing some ‘cleanup’ work on the surfaces first, if the design intent allows.

Later after lunch, I’ll check them out further. :beers: :sandwich:

Hi Bruno - ShrinkTrimmedSrf before exporting. The result is not 100% - a couple of open edges - but not bad.
@Bruno_Suraski - the object has some questiionable surfaces - stacked control points:

I would clean this up - at least, I think I might expect more problems to arise as is.



Thank you, Pascal; I will run ShrinkTrimmedSrf. Would you specify how did you find the stacked cp? I am trying to identify the issues. Is there a specific command to run through it?

Hi Bruno - I saw an unhappy looking edge - which I cannot find at the moment - and had a hunch so I looked for the stacked points .


1 Like