Unroll brep/surface error

I have tried rebuilding the curves, lofting, ruled surface and other components to generate the surface as shown.
Both the GS unroll toll and the Fabtools unroll tool give the warped wrong result as shown.

I have used the same method before without problems, but cant find a fix for this surface.
Any help gratefully received.

Unroll error.gh (9.6 KB)

Anyone with any ideas why I can’t build this surface in a way that it will unroll properly?
Are there any other tools for flattening/unrolling a developable surface?

Pretty strange and i don’t have an explanation. I have a few different unrollers I’ve downloaded over the years and some work here and some don’t. I also had more success lofting the two curves than with Edge Surface.One of them that does work IS from FAbTools, the other is a Python component that came from this thread:

Unroll error2.gh (135.8 KB)

I’m not a Grasshopper user, but I’m familiar with creating “developable” surfaces which can be unrolled without distortion. Can you post a .3dm file with the shape to be unrolled? Keep in mind that while all developable surfaces are ruled surfaces, not all ruled surfaces are developable. It is very easy to create a ruled surface which can not be unrolled without significant distortion.

Hi David.
When I bake the geometry into Rhino including the surface, it unrolls as expected, no issues whatsoever.

I have created these type of surfaces on a regular basis in Rhino and if drawn up correctly, never have issues unrolling.

I’ve produced this surface in Grasshopper using good clean planar curves with various tools, loft, ruled surface, 2edge surface, etc and all unrolled incorrectly as shown with the GH unroll, the fabtools unroll and an unroll Brel tool I found online.

Hi Ethan, thank you for your reply, I will try this when in the office.
I first tried loft and unroll and the fabtools unroll and a unroll Brel component I found online and all gave the same wrong unrolled result.
However, you show a correct unrolled surface, so not sure why this has worked for you and didn’t for me.
Here’s hoping that when I try again using your definition, it works.

Hi Ethan,

I have tried your GH file. When i open the file, i get the same uncorrect result as shown in my original image with all 3 unrollers. In fact, i had already tried all of these on the surface constructed in different ways with the same incorrect unrolled surface produced.

I have updated Rhino, so that cant be the issue. I am using Rhino 6.

Any ideas, anyone?

Here’s yet another unroller, maybe you’ve already tried it… It’s from Dani Abalde’s Peacock plugin. It works on my system for the loft but not the edge surface. As I said earlier, pretty strange.

Unroll error3.gh (16.8 KB)

Ethan, the Peacock unroller works perfectly. Thank you so much.