Unrecoverable error when processing a geometry export


I’m having an issue that when we try to use the export function for the geometry we are getting the following error:

Unrecoverable error ‘UnrecoverableError’ when saving assets resulting from work request

I thought that it had something to do with the grasshopper file that we uploaded, but then I tried exporting the geometry using previous versions of our gh file (where the export worked) and got the same error.

Does anyone know how to solve this? And where is the error coming from?


Are you having this error locally or after you upload the file on ShapeDiver? Where is it reported (Rhino, online platform, browser console…)? I noticed that the topic is tagged in the mac category, are you using the mac version of the plugin? And most importantly, can you post an example file that causes the issue?

@mathieu1 thank you for your response!

I’m having this error on ShapeDiver online platform.

I think that it was tagged as Mac because my main notebook is a macbook, not using any plugin.

I have sent you the file on pvt!

@mathieu1 Hi!

Did you take a look at what could be happening? Thanks in advance!

We could reproduce the bug, it happens because the name of the file you try to export has a special character (“ê”) which is currently being rejected. We are working on a fix for this issue, in the meanwhile you can still export files if you make sure the names only contain standard ASCII characters.