Undo Bug after UnrollSrf with Labels


#1

i unroll a surface with labels and the moment i click on the labels undo steps get futile.
it writes Undoing Text dot properties change and i can undo practically forever.

problem seen in the last WIP, didnt try any other version


(Dan Belcher) #2

Hi @RichardZ

I’m not able to reproduce this item on my computer. Here is what I’m doing to reproduce this item.

  1. Launch RhinoWIP 5E92w.
  2. Open the attached TestUnrollSrf.3dm (3.5 MB)
  3. Run SelAll.
  4. Run UnrollSrf. Select the Labels option and finish the command.
  5. Press command+Z to undo.

Expected Behavior: The UnrollSrf operation is undone.
Actual Behavior: The UnrollSrf operation is undone.

What am I doing wrong?


#3

@dan still one step missing, after the unrolling with labels has processed, click on any of the dots. from then on at least i get this seen in the image below when i try to undo and i can undo forever nothing visible changes other than the list which gets longer and longer and longer and… hey longer :smiley:. if i cmd z right after unrolling it still undoes as you described here.

i recently had reset my preferences which helped to resolve the Bug in DupBorder on PictureFrame but this issue remains. also seen in the new wip just recently released.


(Dan Belcher) #4

Sorry, I’m still not seeing this behavior. After step 4. above:

Run UnrollSrf. Select the Labels option and finish the command.

I selected one of the dots, then I did an undo. It worked as expected.


#5

i deleted the plist file completely, then i even reset the preferences to be sure the outcome is the same.

i made a video to show that i am not dreaming this up, maybe i did not communicate that well even though i believe you did now all steps as i had stated… but for me it does not work no matter what i do.


(Dan Belcher) #7

Thanks for the video. Unfortunately, following your exact steps, I do not see this behavior on my machine. I’m stumped. Perhaps someone else can reproduce this?


#8

hi dan, thanks for checking again… obviously something is with my rhino and resetting the options does not help. this seems though the only real problem which is left. my plist file contains a huge <data> entity which most likely is responsible for it to weigh 7 mb. maybe this is the reason why i keep having problems? maybe somebody can have a look at it before i have to rebuild my settings from scratch?


(Dan Belcher) #9

That sounds wise. Please post the preferences file here or PM it to me if you don’t want to share publicly.