Unable to perform boolean split, split or trim

Hello,

Can someone solve the mistery why I can’t execute boolean split, split or trim on this polysurface.

Both 3 polysurfaces were originated with the same surface, and the top two I can run the commands with no problem and the last one just fails and I can’t figure out why.

Thank you in advance.

01_MCNEELF.3dm (3.3 MB)

Hello - just use 'Split` here, if I understand what you are doing.

-Pascal

Hi Pascal,

I’ve tried it: “Split failed, objects may not intersect or intersections may not split object.”, but this doens’t seem to be correct for me.

Hello- I guess I do not understand then - please post a file with only the objects you are asking about.

-Pascal

The file was attached to the first post.

Here it is again.

Thank you.

01_MCNEELF.3dm (3.3 MB)

Hello - so, these two objects are the ones you are asking about, correct?

image
So, it looks like the problem is the surfaces in your object happen to have a knot line, in this case a fully multiple knot, right on the intersection where the split occurs - bad luck - but you can greatly simplify the faces on the object to be split and not have any internal knots at all by the look of it.

The face outlined in a red curves in the attached file was recreated with no internal knots - compare the points on this surface with the ones on your original

01_MCNEELF_PG.3dm (2.6 MB)

-Pascal

Thank you pascal. Problem solved.

I didn’t quite understood why this problem of the knots occur, since the surface that originated all the objects is the same, is it a software bug or is there any specific reason? It would be great to know, because this issue is something that occurs sometimes.

How do you created the new polysurface without this knots? You duplicated the edges of the old surface, joined them and the extruded a new polysurface?

Also, how do you verify if an object has knots?

Thanks again.

Lourenço