Unable to make right side bar smaller

Hi There,

I seem to be having a strange issue where I am unable to make the right side bar smaller. I can drag it out bigger but will not allow me to make it smaller, which is not great as it is eating into my useable work space.

I believe it has to do with the objects display, as if I select another window to view, i.e blocks, I can make it smaller.

here some screen grabs…

Any help would be most appreciated.



There is a minimum width for the inspector panels.
A couple of the panels still use an old underlying code that allows for a smaller minimum width.
There is a bug report to update these older inspector panels to use the new “ETO” code, then they will all have the same minimum width and won’t change when you try to make them smaller.

HI John,


However for some reason it is different on different files.

Here is the original which does not allow me to make it smaller:

and here is another file I am working on at the same time which allows me to make the side bar smaller when on the object window:

Is there away to resolve this at this moment in time with out waiting for an update?

Its just that this is becoming hard to work without much space, and I would like to keep the side panel viewable for changing attributes, etc, rather than hiding it all together.



Hello, if anyone was able to help with this please that would be most appreciated.


Hi - unfortunately, you won’t be able to resolve that without a fix in a future update.
You can follow any progress on this issue on this page - RH-53989.

Hi Wim,

I have noticed that the issue you are showing it is related to the display icon panel. And that this is using Rhino V6 Beta.

I am using V5 and it is in relation to the Object Properties panel.

I do not understand why this is happening. do you think it cold be an object in my model that is doing this?

Hello, if someone could please help with this.

I have a large file that I am working on, I have tried saving this as different file names, and re opened up… I have also tried copy pasting all the items into a new window but the issue persists.

it would be appreciated if there is someone who can help to resize the ride side bar window Without having to redraw everything that I have spent 2 months working on.




So I found out what the issue is, and posting here, as maybe someone will find this helpful.

The issue is when inserting files as blocks. For some reason this pushes the right hand side bar out about 2 x its normal size.

Would be nice to see a fix for this. As it is a shame to not be able to use the file block insert function without loosing modelling space.

Thanks for that additional information, Andrew!
I tried to reproduce that here on Rhino 5 for Mac but I’m afraid that I didn’t get that behavior.

Also, I don’t think we are planning a new release for Rhino 5 at this point - but perhaps @dan can tell us that I’m wrong about that.

HI Wim,

Ah, ok, that’s strange. Every time I do it this end it pushes the side bar window out when on te object properties tab.

Do you know if there may be another way to insert referenced files without this happening?

We have significantly tuned up the right-hand sidebar and eliminated many of these unfortunate resizing bugs in Rhino 6 for Mac (in an upcoming update). I was just working on this last week so I know how annoying this is. I apologize.

There is a workaround in Rhino 5 for Mac. Instead of using the Block panel in the right-hand sidebar, use it in a window. To do this, navigate to Window > Show Blocks panel. Then, in the right-hand sidebar, you can right-click and uncheck the Blocks panel.

Awkward, I know. Hopefully, we’ll have a fix for this in Rhino 6 for Mac in the wild. Unfortunately, it is a much more difficult fix in Rhino 5 for Mac.

HI Dan, Thank you…

nice to hear I am not the only one who found this frustrating. : ]

for some reason it is when the objects tab is on that pushes out the rights hand side bar. i have tried a few different ways of inserting files as block instances, even changing the file name so that it is shorter [as I though a long file name might have had something to do with it.]