Unable to load RhinoScript.rhp plug-in: Dependent DLL is out of date

Hello All,

On one of my computers which has installed Rhino 6 when trying to load a rhinoscript i got the following message


However the Edit Rhinoscript command works

Any idea how this issue can be fixed?

P.S I tried Rhino WIP and Rhinoscript works…

Hello - please see if RhinoScript is available but not enabled and loaded in Options > Plug-ins page.


That was my first thing to check and It was not enabled.
But even after I activated it still doesn’t work.


It is Enabled but Not loaded.

Right click on it and click Load plug-in.
Does it load or do you get an error?

Yes it gives me this error


This is happening to me sometimes when Rhino 7 updates.
I downloaded Rhino 6 installer and made a “repair” installation, as suggested by McNeels’ support

Thanks Luca i will give it a try asap

If that doesn’t work, see if this gets you sorted:

Please run the SystemInfo command and paste the results here. I want to check on the exact service release of Rhino that you are using

As I and a client are having the same trouble…

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Kommerziell, build 2020-08-25
License details: Cloud Zoo. In use by: *** ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: ***

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 SUPER (NVidia) Memory: 8GB, Driver date: 9-14-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.38

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-14-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\RhinoScriptEditor.rhp “RhinoScript Editor” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - see if running a repair on the V6 installation helps.


1 Like

You might want to try the SR30 release candidate. We were running into cases where RhinoScript couldn’t find one of it’s dependent libraries and made some changes to accommodate for this in SR30.

Yes, thanks. Now its working again.

As a note for you: The only thing my client and I have in common is that we both use RhinoWIP now as well. Maybe the latest update messed something up?

Yep - as Steve says, the 6.30 release should fix this more thoroughly as well.


This worked! Thanks @pascal