Unable to load render plugin?

When I try to render, I get an error “Unable to load render plug-in, render command not available.” I’m running Windows 8.1, Rhino 5 SR10. The problem only occurs in 64-bit Rhino, the 32-bit version works fine. Have tried safe mode, reinstalling Rhino, no luck. Any ideas?

Try right-clicking on the Rhino icon and choose Run As Administrator - does that do anything different?

-Pascal

No change unfortunately.

Hi Parker - in Options > Plug-ins, do you see either of these entries-

Enabled check on or off?

thanks,

-Pascal

1 Like

Sure enough, Rhino Render was somehow unchecked. Thanks pascal!

Hello,

I have the same problem as parkerrueve. For a moment, the “run as admin” solution worked, but now it repeats that the plugin was unable to load. I also checked the options -> plugins. I’ve got always the rhino render check off, but nothing changes if I turn it on. Whe I want to load the plugin, a new window appears saying that “the rhino render was built with an old version of RDK. Please update the plugin and restart rhino.”

Any ideas how to solve it?

Thanks!

@calenthio same issue with her. can anybody help us ? I keep trying every option like run as admin and the checking of the rhino render but it always state old version.

Hi Sarah - so, you check in Options > Plug-ins, and Rhino Render is checked as ‘Enabled’ correct? What version/Service release of Rhino are you running and on what version of Windows?

thanks,

-Pascal

Hi Pascal

Yeop it is enabled but they would say that “the rhino render was built with an old version of RDK. Please update the plugin and restart rhino.” I am using Rhino 5 on Windows 10 which is the latest window. My friends do not have the issue that I am having.

Hi,

Im having the same problem so was wondering if you have found a solution?

I am also looking for answers. I can’t even get RhinoRender to show up in the list of installed plug-ins, and appear to be missing the RendererDevelopmentKit as well. We’re using the version of Rhino5 released May 23, 2016, on Windows 10.

Go into Options > Plug-ins and set the list filter to “All plug-ins”.
Scroll down and find the Render Development Kit and Rhino Render:

Make sure the Enabled check is filled in for both.
If one or both are not Loaded, right-mouse click on the RDK and choose Load plug-in.
Then do the same for Rhino Render.

Now does it work?

3 Likes

Unfortunately, those two items are not listed at all in the list of plugins. If I double-click the RhinoRender.rhp for Rhino 64-bit, I get a Rhino 5 Plugin-Developer run time debugging window with the following error message:

“Plug-in commands must pass a pointer to their parent plug-in. Your command class structure must look like:
MyPluginCommand:MyPluginCommand() : CRhinoCommand( false, false, ::Plugin() )”

I am searching for our old installer for rh50_5.12, but have been unsuccessful in locating it on any number of backups and external drives.

Are you sure you plug-in list filter is set for “All Plug-ins”?

The RDK must be loaded before the Rhino render will load.
I tried to make all of that clear in my message.

Thank you for replying. Your message was clear, but those items do not show up in the Plugins list at all. The plug-in list is set to All Plugins. It’s just weird.

This is 5.13.60523.20140, floating license using our Zoo.

1 Like

Very odd.
The only thing I can guess is somehow the plug-in registration on that system is buggered.

Try this:
Close Rhino
Run REGEDIT
Browse to \HKEY_CURRENT_USER\SOFTWARE\McNeel\Rhinoceros\5.0\Plug-ins
Delete the Plug-ins folder and the folders under it
Close REGEDIT
Start Rhino

The missing registry keys should be recreated and the default plug-ins reregistered so they will load and run.

See if that works

The structure is a little different on my machine(s), but deleting the Plug-ins key and all of its sub-keys didn’t produce any results:

\HKEY_CURRENT_USER\SOFTWARE\McNeel\Rhinoceros\5.0x64\Global Options\Plug-ins

The 32-bit version still works fine, but the 64-bit version still can’t load the default render plug-in. The render development kit and Rhino Render plugin are listed as expected in the 32-bit version, and are not found in the 64-bit version (which is the one we need to use).

double-weird…

Okay, a reinstall worked to get the render plug-in working in Rhino 5 64-bit. Unfortunately, I have a lot of 3rd party plugins that our instructors have insisted upon having installed by default. Now I get to check to see if any of them break Rhino Render…

Those are different plug-ins in a different area of the registry.

Perhaps a better option is to fully uninstall all 4 parts of Rhino V5 in the Control Panel applet, then manually clean out the registry.

Here are the details:
http://wiki.mcneel.com/rhino/5/uninstall

Then reinstall Rhino using the V5 SR13 full installer.

Yep, that’s what I did to get it working again. I have other plug-ins to install that may have caused the problem… I’m sorting through now.