Unable to join curves

I have two curves, which are touching, which are on the same plane, both have end points, and yet I’m constantly getting “unable to join curves”
I tried copying them, extending them then cutting, it’s maddening.
What could be causing this?
Thank you.

Can you upload a 3dm with the problematic curves?

problem crvs.3dm (2.4 MB)

Here is the problem part

I think the problem has been solved. You can download the file and try it again.
problem crvs.3dm (30.8 KB)

Thank you,
What was the problem?

You can see the end point of one line.

Explicitly, you can’t join these curves when their end points don’t meet each other.

How did an end point end up in the middle of a line? I’m totally lost.

Hi - That curve is an open polycurve with 6 curve segments. 2 of those segments are the same and so the end of the polycurve ends up somewhere in the polycurve.

1 Like

Hello, can someone please explain how this was corrected?
I have a similar issue–I cannot join certain lines for no apparent (to me) reason. They are at the same elevation and seemingly connected at the end points etc. Even when I draw a new polyline starting from one of the problem lines it will not join to it, but does join to certain other lines.

Thanks!!

Hello - most likely, if the curves look like they should join but do not, it is one of two things:

  1. The curve ends are actually out of tolerance, you just can’t see it. Use GCon to test.
  2. There are actually two copies of the same curve and these are already joined to each other and cannot be joined further. Use SelClosedCrv to see if that is the case. If so, explode and toss one copy.

-Pascal

Thank you for your quick reply, Pascal. The problem curves are for some reason duplicated and closed, as you suggested.