Unable to export anything but Rhino 6 files but plug-ins appear to be fine on Mac

Hi everyone, These couple of days, I have come across an issue - I couldn’t manage to export to anything but R6 (.3dm) on my Mac. However, I was able to export to .ai and other file extensions on my brother’s Windows laptop. I checked the plug-in settings against those on my brother’s computer and couldn’t’ seem to spot any differences. I suspect it’s something to do with updating to macOS Catalina (v 10.15.3) because before updating, there have been no issues with exporting. Is anyone encountering similar problems, and how do I resolve it? Thanks!


I couldn’t access the drop-down menu and “Rhino 6 3D Models (3dm)” is the only option.


The export plugins are all enabled. I wonder what went wrong?

Can you run the command SystemInfo in Rhino and copy/paste the results here?

I think you’re running the wrong command.
It a Mac, so the command name is “Export”.

Apple Intel 64-bit macOS Version 10.15.3 (Build 19D76) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro15,1
Machine name: Yeung’s MacBook Pro
Language: en-HK (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-3.5.5)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560X
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro 560X (4 GB)
Color LCD (1680 x 1050)

USB devices
SanDisk: Ultra USB 3.0
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Nordic Semiconductor:

Third party kernel extensions
com.symantec.internetSecurity.kext (9.0.2) DB890B87-79FC-3BF1-881A-7B0D8E474C32
com.symantec.SymXIPS (9.0.1) 57E63AE5-3611-3888-AB74-1498668DA171
com.symantec.ips.kext (9.0.1) C16B29F2-627F-3A73-B803-9CC7F1571816
com.symantec.nfm.kext (9.0.0) FA7CC34D-E628-375F-A28D-7E41D986DAFE

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.16.19205.1052
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.16.19205.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.16.19205.1052
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.16.19205.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.16.19205.1052
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.16.19205.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.16.19205.1052
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.16.19205.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.16.19205.1052
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.16.19205.1002

i tried both ‘export’ and ‘export selected’ but both generate the same results - i wasn’t able to click on the drop-down menu and select other file extensions

Okay. My guess is your PLIST is borked. I’m not near my computer so I can’t give you a link. Search the support Wiki or the forum for the instructions.

what you mean is, i have to restore the PLIST to default settings? sorry, i’m not exactly sure how to fix PLIST issues

Yes. That’s why I asked you to search for the instructions.
Here’s the link:
https://wiki.mcneel.com/rhino/mac/resetprefs

Any luck?

thanks John, unfortunately it still doesn’t work. i tried exporting preferences, saved a copy and resetting them. interestingly, after typing in defaults delete com.mcneel.rhinoceros.plist , the terminal prompt returned very quickly and not 15-20 seconds as the instructions mentioned.
[/quote]

Maybe @dan will. have an idea on what to try next week.

Hi @patientrepair-

Odd, for some reason the results of your SystemInfo leave out the Rhino version. That’s unfortunate. Reading further down, it does appear you might be on an older version of Rhino (6.16)? Can you please update to the latest Service Release (6.23, as of today) and see if you have the same problem.

Thanks,
-Dan